Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have CentOS 6.4 on which i am running virtual box. Inside virtualBox i have CentOS based VM which works perfectly fine. The NAT and HostOnly interface have assinged IP Addresses through DHCP and they work just fine.

However i create some internal network interfaces and add custom IP Addresses. It works fine but later after sometime suddenly those IP Addresses are removed automatically. I have no idea why this happens, and because of this my communication stops. I simply statically assign the IP address again and it starts working again which later after sometime, (appox 25 seconds) the configurations are disappeared and interface is left without any ip address.

What could be the problem? your help would be much appreciated.

share|improve this question
up vote 0 down vote accepted

Just that someone else gets across this problem, here i found the solution:

Background:

I used VirtualBox to setup linux machine, update it and install everything, then make a linked clone from this machine every time i have to do something. Problem comes with this setup is when you have configured some interfaces and you create a linked clone (even after reinitialize=ing mac addresses, network interface settings will interfere with base machine). The solution for this is before creating a linked clone, remove all interfaces from VirtualBox settings and create linked clone.

Now when you setup a new machine and re-create network interfaces through virtualBox, there is no problem however the IP address was now resetting because although interfaces exist, but there is no interface configuration file in

/etc/sysconfig/network-scripts/ifcfg-eth0

Solution:

Simple create a ifcfg-eth0 file and most importantly set the field:

BOOTPROTO="none"

and optionally set it with your desired configurations or whatever you want with it, then do a:
service network restart.

After this, whatever you configure temporarily using ifconfig, will stay and no resetting will occur.

PS: since CentOS 6.4, BOOTPROTO=static option no longer exists, and if you do not set BOOTPROTO=none, what ever IP address you assign on linked clone machine, it will reset after few seconds.

share|improve this answer

Thanks for putting up the answer to this. I had the same issue except that it was not eth0 but any other ethernet interface (eth2). In my case Centos is running in VirtualBox but I added more adapters from the base configuration that I had by adding more NIC cards into the PC. I created the ifcfg-eth2 file and added the BOOTPROTO="none" and the issue was resolved. Much appreciated.

share|improve this answer
    
Actually new previous answer did not really work. What I did to get this to work was to update the /etc/sysconfig/network-scripts/ifcfg-eth2 file with the IP address information of the interface : DEVICE=eth2 BOOTPROTO=none ONBOOT=yes NETMASK=255.255.255.0 IPADDR=50.1.1.2 USERCTL=no – vbnewcomer Feb 23 at 16:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.