Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

While I am trying to install Apache with command httpd -k install I am getting an error:

C:\Program Files\Apache24\bin>httpd -k install
Installing the Apache2.4 service
The Apache2.4 service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.
httpd: Syntax error on line 172 of C:/Program Files/Apache24/conf/httpd.conf: Ca
n't locate API module structure `php_module' in file C:/Program Files/php/php5ap
ache2_4.dll: No error

I am using PHP 5.4.16 with Apache 2.4.4 in Windows 8.

My httpd.conf is looks like:

ServerRoot "c:/Program Files/Apache24"
Listen 80
LoadModule access_compat_module modules/mod_access_compat.so
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule allowmethods_module modules/mod_allowmethods.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
LoadModule include_module modules/mod_include.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule php_module "c:/Program Files/php/php5apache2_4.dll"
AddHandler application/x-httpd-php .php
<IfModule unixd_module>
User daemon
Group daemon
ServerAdmin chanchal_ghosh1987@yahoo.co.in
ServerName localhost:80
<Directory />
    AllowOverride none
    Require all denied
DocumentRoot "c:/Users/chanchal1987/Documents/www"
<Directory "c:/Users/chanchal1987/Documents/www">
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
<IfModule dir_module>
    DirectoryIndex index.php index.html
<Files ".ht*">
    Require all denied
ErrorLog "logs/error.log"
LogLevel warn
<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    CustomLog "logs/access.log" common
<IfModule alias_module>
    ScriptAlias /cgi-bin/ "c:/Program Files/Apache24/cgi-bin/"
<IfModule cgid_module>
<Directory "c:/Program Files/Apache24/cgi-bin">
    AllowOverride None
    Options None
    Require all granted
<IfModule mime_module>
    TypesConfig conf/mime.types
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
<IfModule proxy_html_module>
Include conf/extra/proxy-html.conf
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
PHPIniDir "c:/Program Files/php"

Please help me to resolve this issue.

share|improve this question
Note: Without php module server is working fine. –  chanchal1987 Jun 9 '13 at 16:48

1 Answer 1

Modify httpd.conf as follows:

Change name "php_module" to "php5_module" in the line

LoadModule php_module "c:/Program Files/php/php5apache2_4.dll"

Correct line should be

LoadModule php5_module "c:/Program Files/php/php5apache2_4.dll"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.