Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Apache2 on a Debian Linux. I mount a sshfs to the directory /mnt/mountpoint/ (it is mounted on boot time via /etc/fstab). It is accessed with a softlink from /var/www/mountpoint.

When I access the directory with a browser I get a 403.

As fas as I can see the user www-data can not read the directory.

Output of ls as www-data:

d????????? ? ?    ?       ?            ? mountpoint

Output of ls as root:

drwxrwxrwx 1 aneuschitzer www-data 4.0K Jun  5 16:27 

My corresponding line in /etc/fstab

sshfs#reader@targethost:/mnt/mountpoint  /mnt/mountpoint        fuse    ro,noexec,gid=www-data  0 0

First I had the options ro,noexec, I tried without noexec. I have read How to set up sshfs to use www-data and tried adding the gid, but it did not help.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need to enable the options allow_other and/or user_allow_other in /etc/fuse.conf. Otherwise only the user who mounted the filesystem can use it. Once you've made the change, unmount and remount the filesystem.

share|improve this answer
    
Done. Did not change anything. Do I have to add a corresponding option in /etc/fstab? –  Angelo Neuschitzer Jun 10 '13 at 7:10
    
I added allow_other to the options list, now it works. –  Angelo Neuschitzer Jun 10 '13 at 7:14
    
It would be kind of you to accept the answer since it solved your problem. –  Jenny D Jun 10 '13 at 7:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.