Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm unable to get the Autodiscover of Exchange 2010 working. Our email accounts are name@company .com and our AD is company .local

When I open Outlook 2010 and Ctrl + RMK on the icon and select 'Test E-mail AutoConfiguration' I see this:

 SMTP=myname@company.com
Attempting URL https://exchange1.COMPANY.LOCAL/Autodiscover/Autodiscover.xml found through SCP
Autodiscover to https://exchange1.COMPANY.LOCAL/Autodiscover/Autodiscover.xml starting
GetLastError=12007; httpStatus=0.
Autodiscover to https://exchange1.COMPANY.LOCAL/Autodiscover/Autodiscover.xml Failed (0x800C8203)
Autodiscover to https://company.com/autodiscover/autodiscover.xml starting
GetLastError=12029; httpStatus=0
Autodiscover to https://company.com/autodiscover/autodiscover.xml Failed (0x800C8203)
Autodiscover to https://autodiscover.company.com/autodiscover/autodiscover.xml starting
GetLastError=12007; httpStatus=0.
Autodiscover to https://autodiscover.company.com/autodiscover/autodiscover.xml Failed (0x800C8203)
Local autodiscover for company.com starting
Local autodiscover for company.com Failed (0x8004010F)
Redirect check to http://autodiscover.company.com/autodiscover/autodiscover.xml starting
Srv Record lookup for http://autodiscover.company.com/autodiscover/autodiscover.xml Failed (0x80072EE7)
Srv Record lookup for company.com starting
Srv Record lookup for company.com Failed (0x8004010F)

If I go via my browser on a client pc to:

https://exchange1/Autodiscover/autodiscover.xml

I see an XML reply (so I guess this is the autodiscover URL that should be used) (exchange1 is the servername.). This is what I see in my browser:

  <?xml version="1.0" encoding="utf-8" ?> 
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="15:21:30.8211336" Id="2980235674">
  <ErrorCode>600</ErrorCode> 
  <Message>Invalid Request</Message> 
  <DebugData /> 
  </Error>
  </Response>
  </Autodiscover>

When I try this:

  https://exchange1.company.local/Autodiscover/autodiscover.xml 

It ask for my username / password and if I enter them I see the same XML message. Now on my DC in the DNS Manager I have this:

DCSERVER
- Forward Lookup Zones
-- _msdcs.COMPANY.LOCAL
--- dc
--- domains
--- gc
--- pdc
-- COMPANY.LOCAL
--- _msdcs
--- sites
--- _tcp   <---------
--- _udp
--- DomainDnsZones
--- ForestDnsZones

Under the COMPANY.LOCAL > _tcp I have added an SRV record:

_autodiscover    Service Location (SRV) [0][0][443]  exchange1.company.local    static

Could anyone see what I'm missing or misconfigured?

Update:

1) Get-AutodiscoverVirtualDirectory

Gives me:

Name                                    Server                                  InternalUrl
----                                    ------                                  -----------
Autodiscover (Default Web Site)         EXCHANGE1

Looks like I need to set an InternalUrl also. Is this correct?:

Set-AutodiscoverVirtualDirectory -Identity 'Autodiscover (Default Web Site)' -InternalUrl 'https://autodiscover.company.local' 

2)

in the DNS Manager, I only have an SRV _autodiscover Record in _tcp as said in this post. Is this enough? Or should I add an A record with these settings in 'Forward Lookup Zones > COMPANY.LOCAL'?:

Name: autodiscover
Type: Host (A)
Data: <ip of exchange>
share|improve this question
    
I've updated the post. is that update correctly? –  juFo Jun 11 '13 at 15:25
    
When creating an A record, I also created the PTR record. Not sure if this is needed. Let's see if this works. –  juFo Jun 12 '13 at 7:29
    
everything seems fine now :) –  juFo Jun 12 '13 at 9:33
    
I've switched my comments to an "answer". If that didn't fix it and you figured it out yourself, please post your own answer and accept it. Thanks! –  TheCleaner Jun 12 '13 at 13:00

1 Answer 1

up vote 2 down vote accepted

What about on the Exchange side...what are the internal/external URLs configured as? Do you have an A record in DNS for "autodiscover.company.com" (or autodiscover.company.local internally) and does your SSL cert have both names listed?

Set the internalURL and create an A record...both internally and externally (using autodiscover.company.com) if you want the clients to be able to autodiscover from outside too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.