Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to port an old application to a new server and need to install Tomcat5 on CentOS 6.4. This is apparently not a straightforward task.

When I try:

yum install tomcat5 tomcat5-admin-webapps tomcat5-webapps

I receive

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.easynews.com
 * extras: centos.mirror.freedomvoice.com
 * updates: yum.phx.singlehop.com
Setting up Install Process
No package tomcat5 available.
No package tomcat5-admin-webapps available.
No package tomcat5-webapps available.
Error: Nothing to do

How can I go about getting the older version of Tomcat installed and running?

share|improve this question
1  
Is there a specific reason why you try to install an EoL application server with known open security bugs on a fresh server? –  Nils Jun 11 '13 at 21:13
    
moving to a XenServer virtual system, didn't want to use gentoo in a virtual setting and I feel other packages will be more maintainable as centos. While tomcat will have security issues, I'm hoping i can mitigate some of the other older insecure packages. If that makes sense ? –  rreeves Jun 11 '13 at 21:27
2  
CO 6.4 is great. But you should really consider going straight to Tomcat 6.0 or even 7.0 to have an supported system. The migration from 5.5 to 6.0 and 6.0 to 7.0 is described on the Tomcat-webpage. –  Nils Jun 11 '13 at 21:35
    
thanks i will into migrating to 6.0 –  rreeves Jun 11 '13 at 21:39

2 Answers 2

up vote 2 down vote accepted

Tomcat 5 is not available in CentOS repo , you need to install it manually.

 1. Download the version from the below link
    http://archive.apache.org/dist/tomcat/tomcat-5/
 2. Extract the downloaded file.
 3. Change the permission for the conf folder.
 4. start the tomcat from startup.sh file inside the bin directory.

Make sure you have JAVA installed on your server.

share|improve this answer

CentOS 6 ships with Tomcat 6, not Tomcat 5. You can run CentOS 5 for Tomcat 5 or download Tomcat 5 from the archives to run under CentOS 6. You may run into other errors with this, though. YMMV

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.