Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The interface on the JD990A is very cut down. There is a serial console with minimal commands and a web interface. The 3750 is in a 2 switch stack and I am trying to configure cross-stack link aggregation with the HP. Most information online tends towards a better HP switch with cli access this does not have.

Does anyone have any idea what may be required to achieve this?

Cisco 3750: Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9NPE-M), Version 15.0(2)SE2, RELEASE SOFTWARE (fc1)

HP JD990A: Software Ver: 02.00.01

Cisco 3750 Config

!

! Last configuration change at 01:50:10 AEST Thu Jun 13 2013 by administrator

! NVRAM config last updated at 01:50:11 AEST Thu Jun 13 2013 by administrator

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service sequence-numbers

!

hostname 1.c.s.net

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 redacted

!

username administrator privilege 15 secret 5 redacted

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local 

!

!

!

!

!

!

aaa session-id common

clock timezone redacted

switch 1 provision ws-c3750x-24

switch 2 provision ws-c3750x-24

system mtu routing 1500

!

!

!

ip domain-name corp.redacted.com.au

!

stack-power stack PowerStack-1

!

!

!

crypto pki trustpoint TP-self-signed-3311124608

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-3311124608

 revocation-check none

 rsakeypair TP-self-signed-3311124608

!

!

crypto pki certificate chain TP-self-signed-3311124608

 certificate self-signed 01

redacted

    quit

cts server deadtime 0

no cts server test all enable

cts server test all idle-time 0

cts server test all deadtime 0

!

!

!

spanning-tree extend system-id

!

!

!

!

!

!

vlan internal allocation policy ascending

!

ip scp server enable

!

!

!

!

!

interface Port-channel5

 switchport trunk encapsulation dot1q

 switchport mode trunk

 spanning-tree portfast trunk

!

interface FastEthernet0

 no ip address

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

 switchport trunk encapsulation dot1q

 switchport mode trunk

 spanning-tree portfast trunk

 channel-protocol lacp

 channel-group 5 mode active

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8
!

interface GigabitEthernet2/0/1

!

interface GigabitEthernet2/0/2

!

interface GigabitEthernet2/0/3

!

interface GigabitEthernet2/0/4

!

interface GigabitEthernet2/0/5

 switchport trunk encapsulation dot1q

 switchport mode trunk

 spanning-tree portfast trunk

 channel-protocol lacp

 channel-group 5 mode active

!

interface GigabitEthernet2/0/6

!

interface GigabitEthernet2/0/7

!

interface GigabitEthernet2/0/8

!

interface Vlan1

 ip address 10.1.1.242 255.255.255.0

!

ip http server

ip http secure-server

!

!

!

!

line con 0

 logging synchronous

line vty 0

 exec-timeout 0 0

 transport input ssh

 transport output ssh

line vty 1 4

line vty 5 15

!

ntp server 10.1.1.21 prefer

end
share|improve this question
add comment

2 Answers

NOTE: I'm posting this as an answer mainly because a comment was very hard to read. I'm not certain if you are asking how to configure the HP switch or if you want full details on both sides (cisco and HP).

The JD990A is the HP 1905, right? The 3COM OfficeConnect acquisition line?

See these two links:

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c02581623/c02581623.pdf

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c02583125/c02583125.pdf

You should be able to configure LACP on the ports through the web interface of the HP switch to correspond with the LACP config on the ports on the Cisco switch.

Just be sure that you configure the HP side aggregation type as LACP instead of static.

share|improve this answer
    
I am unsure of the technical details of Link Aggr on the HP switch. I am using the LANBASE license so I can't use the L3 options for etherchannel. I am wondering if this may cause a problem linking with the HP. –  Ablue Jun 12 '13 at 14:12
    
That part I don't know...will it let you configure LACP in the web interface on the HP at all? If it's a licensing issue, SF folks won't really be much help. –  TheCleaner Jun 12 '13 at 14:23
    
That is really what I am unsure of. If the HP switch is only trying to achieve LACP at L3 then I think I am stuck, but documentation on this model is sparse. I can configure LACP ok on the web ui and cisco stack is configured, the port channel doesn't come up and lacp port state stays as INDEP. –  Ablue Jun 12 '13 at 14:29
    
Cisco documentation indicate it can operate on L2 with a different feature set. I am guessing the HP unit does not support. I will leave this open a little longer to see if anyone else has anything to say. –  Ablue Jun 12 '13 at 14:35
    
Sorry, I typo'd it. It should have read "LACP is a L2" protocol by default. I'll have to dig a little deeper on the HP side though to see what INDEP means. –  TheCleaner Jun 12 '13 at 15:03
show 4 more comments
up vote 0 down vote accepted

The mode for the channel group needed to be on.

channel-group 5 mode on
share|improve this answer
    
Interesting... mode ON on a Cisco switch is PaGP only. Which switch did you put that command into? –  SpacemanSpiff Jun 24 '13 at 5:54
    
The Cisco one. I discounted using that mode as well but cisco support advised me to use it and it worked. –  Ablue Jun 24 '13 at 5:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.