Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After a few days of trial and error I have successfully created my gluster volume on an EC2 instance (a single one at the moment) and it is successfully started…

[root@domU-12-31-39-10-26-7E ec2-user]# gluster volume info

Volume Name: gv0
Type: Distribute
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: ec2-107-20-245-144.compute-1.amazonaws.com:/export

From my client EC2 instance I have installed gluster and fuse - however when I try to mount the drive I just continually get this error.

[root@ip-10-202-210-190 glusterfs]# mount -t glusterfs upload.themixtapesite.com:/gv0 /var/www/vhosts/i-16852366/wp-content/uploads/gravity_forms/1-9e5dc27086c8b2fd2e48678e1f54f98c/2013/02/gluster
Mount failed. Please check the log file for more details.

All required ports are open in the security group 111, 24007, 24008, 24009 on TCP and UDP just to make sure. Ive disabled selinux on the gluster server just in case it was that. I've even tried to do a "gluster peer probe" from the server to the intended client and it sees it and adds it to its list just fine.

Here are the log errors

[2013-06-13 06:24:41.022793] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.1
[2013-06-13 06:24:41.041254] E [socket.c:1715:socket_connect_finish] 0-glusterfs: connection to  failed (No route to host)
[2013-06-13 06:24:41.041346] E [glusterfsd-mgmt.c:1787:mgmt_rpc_notify] 0-glusterfsd-mgmt: failed to connect with remote-host: Transport endpoint is not connected
[2013-06-13 06:24:41.041372] I [glusterfsd-mgmt.c:1790:mgmt_rpc_notify] 0-glusterfsd-mgmt: -1 connect attempts left
[2013-06-13 06:24:41.041641] W [glusterfsd.c:831:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_transport_notify+0x28) [0x3ae580b018] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0xc0) [0x3ae580f$
[2013-06-13 06:24:41.041684] I [fuse-bridge.c:4648:fini] 0-fuse: Unmounting '/var/www/vhosts/i-16852366/wp-content/uploads/gravity_forms/1-9e5dc27086c8b2fd2e48678e1f54f98c/2013/02/gluster'.

So it obviously can't connect, but I don't know why - I've tried rebooting. Something else obvious I'm missing? Some extra linux software blocking something? I been through about 6 how to guides and tried every step, but nothing.

UPDATE: I can successfully SSH from the client instance to the gluster server instance - so they talk via SSH just fine, but still no luck mounting.

Both the server and the client have GlusterFS v 3.3.1-15 running.

share|improve this question
    
I you move the destination server into a security group with all traffic allowed from source server does it work? –  golemwashere Jun 13 '13 at 14:59
    
@golemwashere I made it so that the other security group was named and gave it access to ALL ports, which should be the same thing - but I will try to put them in the same security group now, just for arguments sake. –  Danny Shepherd Jun 13 '13 at 17:47
    
Ok @golemwashere I cloned the ami and launched it from the same security group as the client, but it made no difference, won't mount, same error log - I don't understand why other people have managed to do this. I wonder if theres something with my linux distro's ? Both are running Centos6.4 –  Danny Shepherd Jun 13 '13 at 18:56
    
You've adjusted the security groups -- is there a firewall up on your server? --> service iptables stop –  jasonbrooks Jun 13 '13 at 23:52
    
Nope, no firewall, ran the command on both server and client just in case though, no change :/ –  Danny Shepherd Jun 13 '13 at 23:56
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.