Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have over 350 users complaining that their mouse cursor keeps jumping around when typing. It seems like it's happening when the protocol is starved for bandwith, but I'm not quite sure yet.

If it only was the cursor moving it would be fine - problem is that it also moves the focus so that they are suddenly writing text in a different place in the document without noticing too late (old people, they stare at their keyboards).

Most users have laptops, and I've also suspected the trackpad not sensing typing (and thus not deactivating one-touch click on the pad), but I got a report today that a desktop user experienced the same.

What could cause this? Is there any way to tune RDP so that it won't happen? I'm lost..

EDIT:

Some more background info on how we have RDP set up:

  • RDP encryption level is set down to "Client Compatible" via GPO in order to support older CE thin clients
  • RDP compression is set to "Balances memory and network bandwidth". Same reason as above, to support older RDP clients
  • All RDP shortcuts for the users are configured to only use visual styles + persistent bitmap caching. We have tested without visual styles, the mouse still jumps around
  • All RDS servers are limited to 16bpp colors, desktop composition and backgrounds are not allowed
  • Our MPLS provider has QoS rules in place to keep RDP above Best-Effort (see EDIT2)

EDIT2:

I've inspected the MPLS providers QoS setup, and something feels wrong here (pastebin).. internal RFC1918 traffic is being prioritized in the class below RDP, but with the same drop probability. I'm thinking that this should be in a class further down the list, with a higher drop probability.

I've talked to several employees today, and it seems like this problem is reproduceable if they fire up a ton of domain-joined computers at once (group policies, WSUS updates and so on).

MPLS provider has been approached, and I'm waiting for a free technician to change the QoS settings to see if this helps. I'm going to dump all traffic but RDP on a single site into Best-Effort and see if it helps.

UPDATE 19.07.2013 Still not solved. Discovered that nearly every laptop is missing the touchpad driver, so the touchpad is not being deactivated while the user types. Baaaad. In addition it also happens with desktop PCs, and on any kind of PC with a bandwidth constrained pipe. I've asked a new question on Network Engineering: http://networkengineering.stackexchange.com/questions/2427/qos-woes-managed-ip-vpn

share|improve this question
4  
(old people, they stare at their keyboards) ಠ_ಠ –  MDMarra Jun 14 '13 at 12:49
    
A lot of people are suggesting this to be a network congestion/bandwidth issue. Can you perform network captures at both source and destination? If the server and/or workstation is 2008R2/Win7 and up, you can use netsh trace start capture=yes, although NetMon or Wireshark suffice as well. This may help you to determine if packets are arriving out of order. –  charleswj81 Jun 18 '13 at 4:12
    
When did this start happening? –  ewwhite Jun 18 '13 at 11:29
    
Client OS's and RDP version? –  TheCleaner Jun 18 '13 at 13:57
    
@TheCleaner The majority is on XP SP3 with RDP 7.0 and Windows 7 with RDP 7.1/8.0. –  pauska Jun 18 '13 at 14:02

8 Answers 8

up vote 5 down vote accepted
+250

If you have a user that this happens to often in a day, give them a straight client/server VPN into the RDP server over their internet connection instead of the MPLS, bypassing QoS and the bandwidth congestion of the MPLS circuits themselves.

If all is well for a few days, then you can set aside bugs/issues within the client or server and focus on the MPLS circuits themselves (QoS, bandwidth, latency, etc.).

share|improve this answer
    
I really can't imagine this being other than a combination of wrong QoS setup plus missing touchpad drivers. I'll accept this answer. –  pauska Jul 19 '13 at 13:07

This is a very common issue when RDP is working with insufficient bandwidth or high latency. I'm not sure if it is a protocol bug or an implementation bug (eg. if packets are arriving out of order and not being reassembled correctly, or if they are being misinterpreted altogether), but the solution is either to increase available bandwidth, or adjust the RDP settings (disable sound, or reduce the resolution or colour depth).

share|improve this answer
    
Is it really that common? I've searched everywhere for more detailed info about this, and there are extremely few articles about it. All I find is people asking the very same question, with no definite answers. –  pauska Jun 17 '13 at 12:38
2  
I've seen it a lot. Most people give up trying to solve it, or claim that the user is brushing their touchpad if on a laptop. –  Falcon Momot Jun 17 '13 at 21:35
4  
I did use the approach of blaming them, until they started outnumbering me :( –  pauska Jun 17 '13 at 22:19

Have you tried to enable compression? Administrative Templates\Windows Components\Terminal Services\Terminal Server\Remote Session Environment\“Set compression algorithm for RDP data”

NOTE: "Terminal Services" is "Remote Desktop Services" in newer systems

share|improve this answer
    
It was dumb of me to not include that in the OP, question updated with more info. –  pauska Jun 18 '13 at 9:26

Like others say, it's caused by either a network bottleneck or hardware. In some if not most RDP clients you can change some settings to optimize for slow/high latency connections by disabling some of the fancy window stuff.

share|improve this answer
    
Answer updated with more background info, sorry for not including that in the first place. –  pauska Jun 18 '13 at 9:27

Wait, what? The focus is changing? That takes a mouse CLICK or a key press. I can't imagine that CLICKING is a result of starved bandwidth. I would expect missed clicks, not phantom clicks.

I think you need to suspect software installed on the RDP server. Maybe start with a new, clean server and don't install anything, then test. If you can't recreate the issue, install one software package and test. Repeat.

You might even need to suspect software installed on the client.

share|improve this answer

I don't think it's bandwidth at all because the problem does not seem to occur if the remote desktop is not full screen and the mouse is on the host's desktop area and not in the remote desktops area. I've seen sooooo many complaints about this with all sorts of responses that put the users through hoops trying this and that and never solving the problem. The problem, I think, is something in the remote desktop protocol and Microsoft needs to fix it. Period.

share|improve this answer

I think this error is due to touchpad mouse driver, I have Samsung laptop, in RDP if I touch or click on mouse pad it immediately disconnects the session. I disabled mouse driver it is working fine.

share|improve this answer
    
I think you're on to something - we're experiencing this issue on certain laptop models, and one of them are samsung. –  pauska Sep 25 '13 at 6:11

I've seen this happen on several machines while on Remote Desktop, it happens to me every few minutes and drives me crazy, the focus moves to where the mouse pointer is sitting on the screen. Happens even though you haven't gone near the touchpad or clicked the mouse (I've even learned to type with my palms in the air to try to avoid the touchpad but that ain't it!) No idea what causes it, seems to only happen while typing, possibly typing fast makes it worse but not sure.

share|improve this answer
    
this does not answer the question asked... –  Petter H Sep 3 '13 at 20:11

protected by Community Apr 15 at 16:41

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.