Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I had two OpenLDAP (a master and a consumer). The master is on Red Hat 6 and consumer was on Red Hat 5. Everything worked well until I upgrade the consumer in Red Hat 6.
The sync between the two works well.

ldapsearch -H ldap://consumer and ldapsearch -H ldap://master work.
ldapsearch -H ldaps://master works, but ldapsearch -H ldaps://consumer hang forever and slapd on the consumer uses 100% of one CPU.

The config is exactely the same between the consumer and the master.
They also have the same slapdkey.pem and slapdcert.pem (I check the md5sum).

I tried to generate a certificat from the consumer but the problem was the same.
When I try openssl s_client -connect localhost:636 | openssl x509 -text on the consumer, same result. On the master it shows me the certificat and everything.
ldap and ldaps is running, and port 636 is open.
Any ideas ?

share|improve this question
Do you have any ACLS with ssf? Do you have TLSCipherSuite set in slapd.conf? Did you separately updgrade/rebuild OpenLDAP? On the consumer, run ldd against slapd and ldapsearch. What's in ldap.conf and .ldaprc? Did you increase loglevel in slapd.conf? –  mr.spuratic Jun 14 '13 at 13:13
pastebin.com/tf2Sw642 So, no I don't have ACLs with ssf. I have TLSCipherSuite set. I upgrade RedHat 5 to 6 which upgrade LDAP. I configure LDAP, and have this issue. I try to reinstall OpenLDAP without any changes. The ldap.conf is the same as the master. There has been a change of OpenLDAP version between RedHat 5 and 6. Now it uses slapd.d, but it's the same. The only thing I see that doesn't work is when I type : "hostname -d" I didn't have the domain, contrary to the master or when I was on RedHat 5. I think the problem is more on the SSL side than on the ldap, but I'm a bit lost. –  ouzmoutous Jun 26 '13 at 12:39
I install OpenLDAP server on another RedHat 6, copied the conf from the customer and it has the same problem. SO it isn't a problem from the upgrade, only a conf problem –  ouzmoutous Jun 26 '13 at 13:03

1 Answer 1

Because it was only the consumer, I purged OpenLDAP server and do it again, it's cleaner and now it works. The only drawback is that I will not know where was the issue, but at least it works again.

Thanks for your time mr.spuratic !

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.