Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've tried to update Ubuntu Server 12.04 to 12.10 on a dedicated server I'm renting, and now it won't boot off the HDD. Netboot with the same kernel works fine, and the same kernel that worked before the update doesn't work now, so it's not the kernel. All the kernels I've tried fail to boot from the HDD, but there are no problems with netbooting.

We built a kernel with netconsole and the NIC driver included, and here is the netconsole output. It does get up to a certain point, but then the messages abruptly stop. I don't see anything that stands out there.

How should I proceed with determining the problem?

share|improve this question

2 Answers 2

This is why real servers have some kind of out-of-band console. From old-school serial port connection to a port concentrator, to more modern ipmi kvm or proprietary OOB connections such as HP's iLO and sun ilom.

Using those, you can simply look at what would be displayed on an attached monitor and see more errors, such as (what would be my first guess) fsck telling you it needs to do its thing.

share|improve this answer
The service provider does offer a KVM option, but at a hefty price :) –  CyberShadow Jun 15 '13 at 9:09

So immediately after it attaches the SCSI disk to sda, usually it starts booting systemd/sysV/upstart services from under /etc on whatever partition got mounted on "/".

This is a working example...

[    1.829051] sd 4:0:0:0: [sdb] Attached SCSI disk
[    1.830043] Freeing unused kernel memory: 1356k freed
[    1.830414] Write protecting the kernel read-only data: 12288k
[    1.834461] Freeing unused kernel memory: 1596k freed
[    1.838150] Freeing unused kernel memory: 1328k freed
[    1.842645] systemd[1]: systemd 201 running in system mode. (+PAM +LIBWRAP +AUDIT +SELINUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ)

Hence I would guess that your grub is not referencing the correct partition /dev/sda{1,2,3} on the ST2000DM001 device, or some other issue with mounting or accessing "/"

[   18.208694] sd 0:0:0:0: [sda] Attached SCSI disk
[   19.768633] ata6: SATA link down (SStatus 0 SControl 300)
[   20.208298] calling  libcrc32c_mod_init+0x0/0x1000 [libcrc32c] @ 301
[   20.208309] initcall libcrc32c_mod_init+0x0/0x1000 [libcrc32c] returned 0 after 2 usecs
[   20.212186] calling  init_btrfs_fs+0x0/0xaa [btrfs] @ 301
[   20.212543] Btrfs loaded
[   20.212561] initcall init_btrfs_fs+0x0/0xaa [btrfs] returned 0 after 348 usecs
share|improve this answer
Thanks. I'm going to try using exactly the same kernel parameters as the netboot. –  CyberShadow Jun 15 '13 at 9:10
Didn't work... I don't think the problem is with mounting "/". –  CyberShadow Jun 15 '13 at 9:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.