Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to follow these directions to create a VM within Azure using the Azure Powershell.

http://www.windowsazure.com/en-us/manage/services/networking/active-directory-forest/

Cmdlet #1

Set-ExecutionPolicy RemoteSigned

Cmdlet #2

Import-Module 'C:\Program Files (x86)\Microsoft SDKs\Windows Azure\PowerShell\Azure\Azure.psd1'

Cmdlet #3

Get-AzurePublishSettingsFile

Cmdlet #3 results in the following error:

Get-AzurePublishSettingsFile : Could not find publish settings. Please run
Import-AzurePublishSettingsFile.
At line:1 char:1
+ Get-AzurePublishSettingsFile
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
   + CategoryInfo          : CloseError: (:) [Get-AzurePublishSettingsFile], FileNotFoundException
   + FullyQualifiedErrorId : Microsoft.WindowsAzure.Management.Subscription.GetAzurePublishSettingsFileCommand

So far MS has recommended the following which have had no effect:

I do see that at least one other person was able to get that URL to work for them here : http://connectedpawns.wordpress.com/2013/06/11/get-azurepublishsettingsfile-could-not-find-publish-settings-please-run-import-azurepublishsettingsfile/

Thanks in advance for any additional suggestions on a fix

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You have a typo in the publishprofile url - it ends in aspx:

https://windows.azure.com/download/publishprofile.aspx

Once you fix that, you'll be able to download your profile and import it.

share|improve this answer
    
I had to double-check my email from MS support.... the typo was theirs. But that did the trick. Thanks! –  BrianAdkins Jun 15 '13 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.