Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So I now I've installed KVM (and its associated tools and packages- libvirt, VMM etc.). On the GUI (i.e using the VMM), installation works as its supposed to. However, when I try to create a VM using the command line interface, the OS (I am working with CentOS 6.3) defaults to a Minimal Install instead of giving me options to choose from at the time of installation. I am trying to install using the following command:

virt-install    \
--connect qemu:///system \
--virt-type kvm  --name testVM2  \
--ram 512  --disk path=/var/lib/libvirt/images/testVM2.img,size=8 --vnc \
--cdrom /media/db18de8e-0853-49fb-80de-5c794d58a46f/CentOS-6.3- x86_64-bin-DVD1.iso   \
--network network=default  

Specifying the OS-type or the OS-variant parameters doesn't make a difference. Is there something that I am missing out on or some other parameter that I must specify?

Thanks in advance.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Can you connect to the VM using vnc? One thing I would try is to rise the ram amount, with 512MB centos will default to a text based installation, try using at least 768 and run a graphical installation, then connect to the vnc (it should happen automatically) and set up your VM as you prefer.

But, if you're trying to provision your VM in an automate way, you should use a kickstart file with the option -x "ks=/network/path/to/your/ks/file. A kickstart file will let you specify everything for your installation (hostname, ip, firewall configuration etc.) including which packages you want to install. If you don't know about kickstart you can read the documentation

share|improve this answer
    
yes, that did the trick. while allotting higher memory, like say 768M or 1024M, it takes me to the GUI console to install and select the type of OS. Just wondering if there is a way to specify it at the time of virt-install..... (I am accepting this answer b'coz it answered my question). Thanks a lot Vilelm... –  i.h4d35 Jun 18 '13 at 15:53
--vnc --vncport=xxx --vncclient=0.0.0.0 
share|improve this answer
    
Welcome to server fault! While the code is nice, it's better if you use full sentences and explain what is needed. This is especially true in this case, where it's not clear why this answers the question. –  Falcon Momot Nov 12 '13 at 4:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.