Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Exporting and importing doesn't work but copying the very files does. Have I broken something?

On a Windows 2012 Hyper-V I tried
copying a VM through
"Export" and then "Import"
and also
"Export" and "New machine" & "Add existing HD".

The VM didn't boot properly but always complained and I was presented with B/W text somewhere after the BIOS. Alas the HD was recognised but not what was on it. Exporting as the docs and intertoobs say don't work it seems.

So I just copy-pasted the very files from the source machine, updated the config.xml (had to keep the name of the VHD though) and started the VM. Worked properly.

Now I have to update the machine name and the SID but disregarding that - Are there any drawbacks with what I did? (especially breaking stuff)

Addendum:
The source VM had snapshots and I have been warned that it messes up machine cloning.

share|improve this question
    
"but always complained" - yeah. Works here. Maybe if you would say HOW it complained we could help you to - well - you know - FIX the problem. –  TomTom Jun 18 '13 at 13:48
    
@TomTom Yes I know - unfortunately I didn't capture the output. –  LosManos Jun 18 '13 at 14:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.