Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I seem to be facing a rather strange problem.

I have a server running on Amazon EC2. It's a CentOS server with Plesk. I have filled the form to lift the email sending limit set by Amazon, and have received the confirmation that the limit has been lifted. And yet, postfix can't seem to be able to send any email:

Jun 19 18:37:54 user postfix/smtp[27934]: connect to example.com[xx.xx.xx.xx]:25: Connection timed out
Jun 19 18:37:54 user postfix/smtp[27934]: xxxxxxxxxxx: to=<dest@example.com>, relay=none, delay=9084, delays=8934/0.17/150/0, dsn=4.4.1, status=deferred (connect to example.com[xx.xx.xx.xx]:25: Connection timed out)

However, I can send emails without any problem using telnet on port 25.

I'm confused. Any help on where to look or what the issue might be will be more than welcome.

share|improve this question
    
Is it the same server identified in the log message that you tried to telnet to? –  Falcon Momot Jun 19 '13 at 17:44
    
Yes. To clarify, postfix can't send emails to any server, not just one. With telnet I have been able to send emails to several ones (all those that I've tried really), including those that cause postfix to time out. –  lmontrieux Jun 19 '13 at 17:47

1 Answer 1

up vote 0 down vote accepted

As this was a server that had to be put in production much earlier than initially planned, I had no other choice than to go for the nuclear option. I instructed Plesk to switch to Qmail, and since then, emails are being sent just fine.

If anyone knows what was possibly wrong with my postfix setup, I'm still curious, though. I'd rather know what was going on so I don't have to deal with it again on another server.

share|improve this answer
    
Why don't you edit your question instead of posting the exact solution that I recommended to you ? –  cept0 Jun 24 '13 at 6:42
    
Presumably because I posted my answer on the 19th of June, whilst you posted yours on the 22nd of June, i.e. 3 days later. So, tell me: Why did you post the exact solution I had posted 3 days earlier? –  lmontrieux Jul 1 '13 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.