Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So the new CentOS VPS didn't come with mbstring enabled. Easy enough, right? I typed 'yum install php-mbstring' It then says "Error: Nothing to do." The only thing I can figure is that I'm missing the repository for the php functions. I'm kind of surprised that this isn't included by default given how imperative it is for web servers. Since I'm used to Debian systems, I'm not really all the familiar with adding repositories for RHEL systems.

Anybody have any suggestions for getting this installed and working?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Are you sure that php-mbstring isn't already installed? You might just have to enable mbstring in php.ini

See thisenter link description here

Reinstalling php and enabling it via the installer might work too.

share|improve this answer
    
Good point. Just for good measure, I edited php.ini and enabled php-mbstring there. However, this didn't fix the issue. When issuing the command "php -m" to see which modules are installed, mbstring isn't listed among them. Still, when trying to yum install it, yum reports that no package by that name is available. –  revickulous2001 Jun 21 '13 at 1:31
    
To correct the issue, I ended up having to re-compile and re-install Apache. Mbstring wasn't enabled during the initial compilation. So that corrected the issue. –  revickulous2001 Jun 23 '13 at 22:37
    
and why you didn't use apache from official repo? –  ALex_hha Jul 2 '13 at 22:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.