Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to automate acceptance testing by using vagrant to bring up machines with amazon's EC2 service, so I added the dummy box and copied the Vagrantfile off Github, but when I try to run vagrant up --provider=aws I get the output below: I'm fairly new to ruby and so I'm not sure what exactly is going wrong.

Bringing machine 'default' up with 'aws' provider...

[default] Warning! The AWS provider doesn't support any of the Vagrant
high-level network configurations (config.vm.network). They
will be silently ignored.
[default] Launching an instance with the following settings...
[default] -- Type: m1.small
[default] -- AMI: ami-5344d263
[default] -- Region: us-east-1
[default] -- Keypair: vagrant-keypair
/home/vagrant/.vagrant.d/gems/gems/excon-0.25.0/lib/excon/middlewares/expects.rb:10:in response_call': Expected(200) <=> Actual(400 Bad Request) (Excon::Errors::BadRequest) from /home/vagrant/.vagrant.d/gems/gems/excon-0.25.0/lib/excon/connection.rb:353:in response' from /home/vagrant/.vagrant.d/gems/gems/excon-0.25.0/lib/excon/connection.rb:247:in request' from /home/vagrant/.vagrant.d/gems/gems/fog-1.10.1/lib/fog/core/connection.rb:21:in request' from /home/vagrant/.vagrant.d/gems/gems/fog-1.10.1/lib/fog/aws/compute.rb:384:in _request' from /home/vagrant/.vagrant.d/gems/gems/fog-1.10.1/lib/fog/aws/compute.rb:379:in request' from /home/vagrant/.vagrant.d/gems/gems/fog-1.10.1/lib/fog/aws/requests/compute/run_instances.rb:119:in run_instances' from /home/vagrant/.vagrant.d/gems/gems/fog-1.10.1/lib/fog/aws/models/compute/server.rb:173:in save' from /home/vagrant/.vagrant.d/gems/gems/fog-1.10.1/lib/fog/core/collection.rb:52:in create' from /home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.2.2/lib/vagrant-aws/action/run_instance.rb:76:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.2.2/lib/vagrant-aws/action/warn_networks.rb:14:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.2.2/lib/vagrant-aws/action/sync_folders.rb:21:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/provision.rb:45:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in block in run' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/util/busy.rb:19:in busy' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in run' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/call.rb:51:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.2.2/lib/vagrant-aws/action/connect_aws.rb:41:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/config_validate.rb:25:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builder.rb:116:in call' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in block in run' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/util/busy.rb:19:in busy' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in run' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/machine.rb:147:in action' from /opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/batch_action.rb:63:in block (2 levels) in run'

Error when running after recompiling:

An error occurred while executing multiple actions in parallel. Any errors that occurred are shown below.

An unexpected error ocurred when executing the action on the
'default' machine. Please report this as a bug:

undefined method `Errors' for Excon:Module

/home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.3.0.dev/lib/vagrant-aws/action/run_instance.rb:91:in `rescue in call'
/home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.3.0.dev/lib/vagrant-aws/action/run_instance.rb:61:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.3.0.dev/lib/vagrant-aws/action/warn_networks.rb:14:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.3.0.dev/lib/vagrant-aws/action/sync_folders.rb:21:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/provision.rb:45:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in `block in run'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/util/busy.rb:19:in `busy'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in `run'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/call.rb:51:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/home/vagrant/.vagrant.d/gems/gems/vagrant-aws-0.3.0.dev/lib/vagrant-aws/action/connect_aws.rb:41:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/config_validate.rb:25:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builtin/handle_box_url.rb:72:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/warden.rb:34:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/builder.rb:116:in `call'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in `block in run'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/util/busy.rb:19:in `busy'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/action/runner.rb:61:in `run'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/machine.rb:147:in `action'
/opt/vagrant/embedded/gems/gems/vagrant-1.2.2/lib/vagrant/batch_action.rb:63:in `block (2 levels) in run'
share|improve this question

1 Answer 1

You may benefit from this patch which should log the actual bad response: https://github.com/mitchellh/vagrant-aws/pull/101

share|improve this answer
1  
Welcome to Server Fault! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. –  slm Jun 22 '13 at 3:56
    
Tried using this patch and compiled it from source, still getting the same error. –  Jordan Jun 24 '13 at 16:23
    
Scratch that, compiled it again and outputs a different (no less cryptic) error –  Jordan Jun 24 '13 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.