Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a heck of a time getting port forwarding setup on an Arris TG862. I am trying to forward port 80 to a machine on my network but I am having exactly zero luck. Here is my setup:

The Arris is the modem/router and DHCP is running on it. The NAT mode is RoutedWithNAT. Now plugged into the Arris is another router that also has DHCP running; Arris hands out IPs with 192.168.0 addresses and the second router hands out 192.168.1 addresses. The second router and what is connected to it should't be of any concern for this conversation (I think) since the computer I am trying to forward 80 to is connected directly to the Arris. Its IP Address is 192.168.0.2 and the machine itself is a Windows Server 2008 R2 install running WAMP.

WAMP is up and running as I can view it through localhost (duh) but I can also go to 192.168.0.2 from one of the PCs on 192.168.1 and the server displays the page fine so I know that the server is at working on the private network. In the Arris I setup a 'Virtual Server' (port forward) and set the Inbound port range to 80-80, provided .0.2 as the private address and 80-80 as the private port range. Nothing happens.

I then used Shields Up! to do a port scan of my IP and it didn't detect any ports whatsoever. So I dropped the firewall on the Arris, re-ran Shields Up! and I could see a bunch of ports; most were closed some were stealthed. Of interest port 80 is stealthed so I don't know if the Arris is actively blocking port 80 or what. Nevertheless I tried to access the webserver on my internal machines now that the firewall was down with the same result. I disabled to firewalls completely on the server. Nothing. As a last ditch effort I setup a port forward of Inbound port range 15386-15386 to private range 80-80 on .0.2 and tried http://xxx.xxx.xxx.xxx:15386 again, with the same result. It I port scan 15386 though it does show up as closed, not stealthed, but also not open.

Any help that anyone can give would be greatly appreciated!

share|improve this question

1 Answer 1

Did you try accessing it outside of your lan, from the internet? I had the same problem here, and the issue seems to be the Arris does not forward for the internal lan. None of the firewall settings had any effect when on the private network.

I'm struggling to find if this is by (bad) design. So yes, Virtual Servers (port forward) does work, but you need to be external.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.