Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Kaspersky Endpoint security, but as soon as the installer finished, my remote desktop connection broke and I wasn't able to login anymore.

Seems that Kaspersky firewall blocks RDC ports and that prevents me from logging in.

I can't connect to the server at all to change the settings.

Are there any alternatives of logging into the server? What can I do to change those settings?

Thanks

share|improve this question

2 Answers 2

up vote 5 down vote accepted

You can use an ILO/DRAC if it's a physical server.

You can use the hypervisor console if it's a virtual machine.

You can try configuring Windows Firewall via Group Policy, if Kapersky AV reconfigured the Windows firewall. Some AV products simply flip on the Windows firewall, which blocks RDP by default.

If instead Kapersky AV implemented its own firewall, then... well you get in your car and you drive out there to where the machine is, or call the datacenter and pay for remote-hands, and learn your lesson.

share|improve this answer
    
Thanks for quick answer Ryan. Seems that Kaspersky installed its own firewall, which might even clash with the one from Windows. So my only option right now is to call the hosting company and ask them to login from there to change the settings? –  Ivanhoe123 Jun 23 '13 at 16:44
    
Yes, based on the information supplied, I can think of no other alternatives besides what I've already mentioned. –  Ryan Ries Jun 23 '13 at 16:48
    
Got it - thanks again for such quick response! –  Ivanhoe123 Jun 23 '13 at 16:50

If you have access to a machine that is able to forward a specific port to the RDP host, then you might be lucky.

Kaspersky prevents RDP connections from other networks, but it may allow RDP from the same subnet.

So, if you have a firewall or a linux machine for example, that you can ssh into and just forward a port over a local machine, it could work.

ssh -l <username> -L 3399:<rdp-target-ip>:3389 <gateway-host>

then you can connect to localhost:3399 on your remote dektop client to access the remote RDP machine.

share|improve this answer
    
Point about subnets makes sense but this is about Windows server, not Linux unfortunately. –  Ivanhoe123 Jun 23 '13 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.