Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I was trying to install php 5.4 on Centos 6.3 and I decided to go with the webstatic version. I've tried to to install imagick using the followng commands

pecl install imagick
yum install php54w-pecl-imagick
yum install php54w-imagick

But each to no avail. Is there a way to install imagick using php54w?

share|improve this question
What is the problem you are having? – Michael Hampton Jun 25 '13 at 18:37
The pecl package throws an error when using autodetect and the other two packages don't exist. – Devin Dixon Jun 25 '13 at 20:03
Webtatic has since added the imagick extension, so your first yum command yum install php54w-pecl-imagick would work – Andy Sep 5 at 19:49

1 Answer 1

You can use IUS Community repo - But first of all you need to uninstall previously installed php packages. And the execute the following commands

# rpm --import
# rpm -ivh
# yum install php54-pecl-imagick

P.S. I assumed that you have used x64 arch

share|improve this answer
FWIW on CentOS 5 the RPM is found at:‌​s.el5.noarch.rpm – doublesharp Aug 18 '14 at 23:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.