Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Background: I've been dealing with some weird issues with my Centos 5 server, it's a dedicated server at a hosting service, so I don't have physical access to it.

Problem: Last night I was doing some stuff like generating SSL certificates (manually) and adding some VirtualHosts to Apache, just some plain stuff, and nothing seemed out of the ordinary, and when I went to sleep I just put my laptop into hibernation (like I usually do), leaving the PuTTY consoles open (two of them). When I tried to log in this morning, at first I was able to log in, but then when I tried to run a sudo (just editing a nonimportant file) I was prompted for the password, I gave it and then the server just hangs, doing nothing. So I closed the console window, and tried to log in via another PuTTY window, but then the server prompts me for username and then password, but always hangs after I punch in the pwd! I've rebooted the server, but no luck, I can't reach the guy at the hosting company and the few websites I was running are down! I'm a little afraid that my server might have been hacked, but I really don't know how to resolve this?

And I think it's really weird that the server answers pings, and presents me with a login screen, but after giving the password it hangs. Would I be able to ping and get a login screen if I were under a DOS attack?

Based on the information I've given, do you have any idea what's wrong?


Edit: I'm not able to execute commands via SSH directly either (that is without starting a shell) and AFAIK the host (which I btw cannot reach) unfortunately doesn't provide IP-KVM.

Another bit of useful info, there is definitely some swapping going on, before my last shell went unresponsive the IO was off the hook, but nothing seemed to be going on in top

Thanks for all input so far, and if any of you have other ideas please share.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

A wild guess is that the server is out of memory and swapping. I've had it happen that I can ssh in, but when the shell starts up it hangs.

You may want to try and send some commands over ssh without logging in and starting a shell.

share|improve this answer
    
Sounds right, but rebooting should have at lease given enough time to login and look around. –  David Aug 9 '09 at 3:18
    
When the host finally rebooted the server, everything was in order. I don't really know what happened but rebooting can work wonders. –  aright Aug 9 '09 at 13:07

If you absolutely cannot access the server over the network, your last option may be to contact your hosting provider and ask if they offer any kind of IP-KVM solution to access your server. This will allow you to have remote access to the local console of the server, and do whatever you might need to do.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.