Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have configured DirectAccess on my Server 2012 Essentials box and most of it works great - I can remotely access the server via RDP and the default IIS website on port 80.

However, I can't access anything that uses other ports. For this example, the Team Foundation Server website. The only way to access it is by accessing http://localhost:8080/tfs on the server directly - even when using http://servername:8080/tfs or won't work.

I've tried adding the ports to the NAT exceptions using Set-NetNatTransitionConfiguration –IPv4AddressPortPool and while that has allowed some ports used internally (Deluge, for example) it hasn't allowed me access to the URL.

I think I've narrowed it down to the "DirectAccess Server Settings" Group Policy that is created when configuring DirectAccess. When I disable the link for this GPO, the TFS site works again, any HTTPS sites (the default IIS one, for example) stop working.

I already have rules in the firewall on the server for TFS and before enabling this Group Policy (so before configuring DirectAccess) I could access both sites. If I fully disable DirectAccess it also works again, so there's something in setting up DirectAccess that's breaking it.

Does anybody have any suggestions for things I can change to allow access to both? I've uploaded the full GPO report and my Remote Access Configuration Summary for more details.

share|improve this question
I've ended up turning DirectAccess off for now and everything is back to normal, but if anyone has an answer that'll allow me to turn it back on, please add it below. – StormPooper Jul 6 '13 at 14:05

The services I'm running are more for a home environment but they listen on

I found that DirectAccess takes the Primary IP address on your NIC for itself. IIS still works about that's about it.

In my experience, I added another IP address to my NIC and now I'm good.

So my NIC on my server now has, and

I can access my services which are listening on at and DirectAccess is setup on

share|improve this answer
Good idea, I'll give that a shot. – StormPooper May 9 '14 at 9:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.