Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After restarting a XCP 1.6.10 host machine, XenCenter 6.1 is no longer able to connect to it. The failure message is always "Server failure: Unauthorized". Using ssh with the exact same root credentials works fine.

I can't seem to find any log on the box that would help me to diagnose this issue, is there any place where connection attempts to openwsmand are logged?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If anyone stumbles across the same phenomenon, here's what I found out (spoiler: I'm stupid):

Of course, what should have immediately raised an alarm was the fact that I wrote openwsmand when the xapi process is actually responsible for handling connection attempts from XenCenter and the likes. What happened here was that I just did a simple netstat -plant and noticed that openwsmand was listening at port 443, which I knew was the port that XenCenter tried to connect to, so I assumed this was the right process.

But of course, XenCenter can't connect to openwsmand because this is a tool of the OpenManage Suite by Dell. I suppose that when I first installed OpenManage, openwsmand tried to bind to port 443, but this was already in use by xapi, so it gave up and I was still able to connect.

When I restarted the machine, however, the openwsmand service was started before xapi, so it occupied port 443, leaving me with no possibility to connect using XenCenter.

A simple

$ service openwsmand stop
$ xe-toolstack-restart
$ service openwsmand start

fixed the problem. Currently running VMs won't be affected by this operation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.