Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm installing 14 Ubuntu 12.10 amd64 servers in an IBM Bladecenter.. I'm having trouble getting past the partitioner step with the preseed file I made.

I think I'm having a problem here boot-root :: \ 40000 50 41000 ext4 \ $primary{ } $bootable{ } \ method{ format } format{ } \ use_filesystem{ } filesystem{ ext4 } \ mountpoint{ / } \ . \ 500 10000 1000000000 ext4 \ method{ format } format{ } \ use_filesystem{ } filesystem{ ext4 } \ mountpoint{ /local } \ . \ 32000 512 33000 linux-swap \ method{ swap } format{ } \ .

Appreciate the help.

    d-i debian-installer/locale string en_US
    d-i console-setup/ask_detect boolean false
    d-i keyboard-configuration/layoutcode string us
    d-i netcfg/choose_interface select auto
    d-i netcfg/disable_autoconfig boolean true
    d-i netcfg/get_nameservers string 9.0.130.50,9.0.128.50
    d-i netcfg/get_ipaddress string 9.56.120.205
    d-i netcfg/get_netmask string 255.255.254.0
    d-i netcfg/get_gateway string 9.47.224.1
    d-i netcfg/confirm_static boolean true
    d-i netcfg/get_hostname string bise
    d-i netcfg/get_domain string pok.ibm.com
    d-i netcfg/wireless_wep string
    d-i mirror/country string manual
    d-i mirror/http/hostname string archive.ubuntu.com
    d-i mirror/http/directory string /ubuntu
    d-i mirror/http/proxy string
    d-i clock-setup/utc boolean true
    d-i time/zone string US/Eastern
    d-i clock-setup/ntp boolean true
    d-i partman-auto/disk string /dev/sda
    d-i partman-auto/method string regular
    d-i partman-lvm/device_remove_lvm boolean true
    d-i partman-md/device_remove_md boolean true
    d-i partman-lvm/confirm boolean true
    d-i partman-auto/expert_recipe string
    boot-root :: \ 40000 50 41000 ext4 \ $primary{ } $bootable{ } \ method{ format } format{ } \ use_filesystem{ } filesystem{ ext4 } \ mountpoint{ / } \ . \ 500 10000 1000000000 ext4 \ method{ format } format{ } \ use_filesystem{ } filesystem{ ext4 } \ mountpoint{ /local } \ . \ 32000 512 33000 linux-swap \ method{ swap } format{ } \ .
    d-i partman/default_filesystem string ext4
    d-i partman-partitioning/confirm_write_new_label boolean true
    d-i partman/choose_partition select finish
    d-i partman/confirm boolean true
    d-i partman/confirm_nooverwrite boolean true
    d-i partman-md/confirm boolean true
    d-i partman-partitioning/confirm_write_new_label boolean true
    d-i partman/choose_partition select finish
    d-i partman/confirm boolean true
    d-i partman/confirm_nooverwrite boolean true
    d-i passwd/root-login boolean true
    d-i passwd/make-user boolean false
    d-i passwd/root-password password passw0rd
    d-i passwd/root-password-again password passw0rd
    d-i user-setup/encrypt-home boolean false
    d-i pkgsel/include string openssh-server build-essential
    d-i grub-installer/only_debian boolean true
    d-i grub-installer/with_other_os boolean true
    d-i finish-install/reboot_in_progress note
    d-i cdrom-detect/eject boolean false
share|improve this question

1 Answer 1

boot-root :: 40000 50 41000 ext4

Try using ext3 instead of ext4 there.

You don't actually give the error you encounter, but I'm fairly sure the fourth entry corresponds to the partition ID, not the filesystem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.