Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to have the jenkins java application run at startup, run as the jenkins user. I have a upstart conf file located at /etc/init/jenkins.conf with the following inside it.

description "Jenkins daemon"

start on startup
stop on shutdown

task

setuid jenkins
setgid jenkins
java -jar /usr/local/lib/jenkins/jenkins.war

Running service jenkins start just hangs. I have tried numerous combinations of upstart internals but cannot find a collection that works, it hangs every time. Is there any error reporting anywhere that I can look at to see what is going wrong? Logged in as the jenkins user I can start the application with that java command.

share|improve this question
    
Have you tried providing the full path to the java executable? why not use a lightweight container and the jenkins war? Odds are the container provides an init.d or upstart script already. –  dawud Jun 29 '13 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.