Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I noticed that my gammu-smsd daemon running on ubuntu is suddenly not sending messages (the sentitems table of my postgresql database is not being updated). First, I noticed that the damemon was not running so I restarted it:

$ sudo /etc/init.d/gammu-smsd start
 * Starting Gammu SMS Daemon gammu-smsd    [ OK ]

Then I checked the syslog (which is the log I configured gammu-smsd to report to):

Jun 27 15:33:04 porkypig gammu-smsd[19267]: Configuring Gammu SMSD...
Jun 27 15:33:04 porkypig gammu-smsd[19267]: SHM token: 0xffffffffce020154 (-838729388)
Jun 27 15:33:04 porkypig gammu-smsd[19267]: Warning: No PIN code in /etc/gammu-smsdrc file
Jun 27 15:33:04 porkypig gammu-smsd[19267]: commtimeout=30, sendtimeout=30, receivefrequency=0, resetfrequency=0
Jun 27 15:33:04 porkypig gammu-smsd[19267]: checks: security=1, battery=0, signal=1
Jun 27 15:33:04 porkypig gammu-smsd[19267]: deliveryreport = no
Jun 27 15:33:04 porkypig gammu-smsd[19267]: phoneid =
Jun 27 15:33:04 porkypig gammu-smsd[19268]: Using PGSQL service
Jun 27 15:33:04 porkypig gammu-smsd[19268]: Connected to database: smsd on localhost. Server version: 80414 Protocol: 3
Jun 27 15:33:05 porkypig gammu-smsd[19268]: Database structures version: 11, SMSD current version: 11
Jun 27 15:33:05 porkypig gammu-smsd[19268]: Table check succeeded
Jun 27 15:33:05 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:33:22 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:33:22 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:33:22 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:33:32 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:33:32 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:33:32 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:33:42 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:33:42 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:33:42 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:33:52 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:33:52 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:33:52 porkypig gammu-smsd[19268]: Going to 30 seconds sleep because of too much connection errors
Jun 27 15:34:22 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:34:32 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:34:32 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:34:32 porkypig gammu-smsd[19268]: Going to 30 seconds sleep because of too much connection errors
Jun 27 15:35:02 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:35:12 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:35:12 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:35:12 porkypig gammu-smsd[19268]: Going to 30 seconds sleep because of too much connection errors
Jun 27 15:35:42 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:35:52 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:35:52 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:35:52 porkypig gammu-smsd[19268]: Going to 30 seconds sleep because of too much connection errors
Jun 27 15:36:22 porkypig gammu-smsd[19268]: Starting phone communication...
Jun 27 15:36:32 porkypig gammu-smsd[19268]: Error at init connection No response in specified timeout. Probably phone not connected. (14)
Jun 27 15:36:32 porkypig gammu-smsd[19268]: Terminating communication No response in specified timeout. Probably phone not connected., (14, 250 times)
Jun 27 15:36:32 porkypig gammu-smsd[19268]: Going to 30 seconds sleep because of too much connection errors     

Does this mean that the modem plugged into the serial port of the computer is not responding? (I access machine via ssh and I don't want to have to physically go to computer if not required.)

Note though that I can run "sudo minicom" and get the following:

Welcome to minicom 2.4

OPTIONS: I18n 
Compiled on Jan 25 2010, 07:02:36.
Port /dev/ttyS0

Press CTRL-A Z for help on special keys  

However, minicom does not let me type any at commands in the window. It just shows a blinking cursor. While I am able to use ctr+A and z and other control+a shortcuts to access menus, I am unable to type any at commands in the window.

The minicom log looks like this:

$ cat minicom.log
20130610 17:57:50 Hangup (0:10:29)
20130611 10:47:56 Gone offline (0:00:02)
20130611 10:53:59 Hangup (0:00:00)
20130611 12:51:50 Hangup (0:00:00)
20130612 00:43:39 Hangup (0:00:00)
20130616 21:45:54 Hangup (0:00:07)
20130624 14:22:48 Hangup (0:01:43)
20130624 14:26:02 Hangup (0:02:58)
20130624 16:58:52 Hangup (2:19:25)
20130625 15:04:39 Hangup (0:03:54)
20130626 10:43:19 Hangup (0:08:13)
20130627 15:46:02 Hangup (0:00:35)

Any idea why the sms messages are not being sent?

share|improve this question
    
hah, same happened to my ZTE USB modem this week, unplug/plug didn't help. –  GioMac Jun 27 '13 at 23:13
    
unplug/plug actually did work for me –  JohnMerlino Jun 28 '13 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.