Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a problem migrating active directory to Gapps. I'm stuck on google apps directory sync (GADS) where it just gives the error "java.lang.NullPointerException" after testing the connection during the LDAP configuration step. I checked the logs and I've pretty much determined that port 389 (standard LDAP port) isn't listening on the exchange server. I've tried telneting to it (from another machine in the same network) with no luck but I can telnet to other ports, that i know are open, successfully. I know they're open because I used portqry and netstat to see them. I'm suspecting that the active directory isn't even installed/running on this machine because there's no active directory services at all running on it. There's no active directory services that say they're NOT running either though. Is it possible AD is installed somewhere else? does it have to be on a machine inside the same network? I found the domain controller and it's host name and when I telnet with port 389, it works however GADS still gives me the same exact error when I substitute that server in. Actually, no matter what ridiculous settings i put into GADS, i still get that same NullPointer error. If i could get some different error than that NullPointer, i'd call that a successful day.


migration rejected from superuser.com Jun 27 '13 at 23:47

This question came from our site for computer enthusiasts and power users. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as unclear what you're asking by Tom O'Connor Jun 27 '13 at 23:47

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

This is one long run on paragraph, I'm not quite sure what's being asked here. Please take the time to format your question more clearly. –  David Jun 26 '13 at 18:38
Well I don't mean to answer my own question, but it was simple. I was trying to connect GADS to the wrong server. I needed to point to the domain controller. My run on paragraph was my excitement/frustration showing it's evil head. Thanks. –  dewnix Jun 26 '13 at 19:39
It's easy to get excited/frustrated when describe an issue, but it does make it harder for the next person who has the same issue to understand the problem. Now that the dust has settled, there is nothing wrong with revising and/or writing up a detailed answer to your own question so that the next person who comes along knows how to solve the issue. –  David Jun 26 '13 at 19:58
Feel free to answer your own question, now that the 8 hours has passed. –  Michael Hampton Jun 27 '13 at 20:48