Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a Centos server with a Samba 3.6. The Samba Config are written below:

[global]
log level =2
follow symlinks = yes
wide links = yes
unix extensions = no
hide dot files = no
socket options = TCP_NODELAY IPTOS_LOWDELAY
security = share
passdb backend = tdbsam


[AsgardServer]
path = /local/asgard/asgard_server
public = yes
writable = yes
browseable = yes
guest ok = yes
follow symlinks = yes
wide links = yes
unix extensions = no
hide dot files = no

Then I mount it to the windows as R:/ and it seems fine.But the security properties of the file under R:/ are Specific, not full control. All those files on the server are 0777 and the owner are the root.Then I cannot modify those files on windows. So whats wrong?

share|improve this question
    
When changing permission in windows and return failed,I can see such period in samba log:[2013/06/28 16:11:18.465525, 2] smbd/posix_acls.c:2850(set_canon_ace_list) set_canon_ace_list: sys_acl_set_file type file failed for file Platform1000/workspace/tc/asgard/basic/AsgardSleep.tc (Operation not supported). –  Daemoneye Jun 28 '13 at 8:14
add comment

1 Answer

On of the solutions to set owners would be to add for each share read/write list. You can specify users

    read list = bob123 anna456
    write list = bob123 anna456

or use groups that are defined in /etc/groups

    read list = @dwarfs
    write list = @wizards

To set file/dir mode (in sense of chmod) you can play with parameters below:

    force create mode = 0666
    force directory mode = 6775

or

    create mask = 644
    directory mask = 755

The directories with data have to have unix permission allowing bob123 anna456 to read and write in them. If directory /local/asgard/asgard_server is owned by root and it has flag 755 neither Bob nor Anna can write in this directory using samba share.

share|improve this answer
    
But under /local/asgard/asgard_server there are many files whose bitmask is 777 and the owner is root. And those files can not be modified. –  Daemoneye Jul 1 '13 at 1:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.