Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed Postfix & Dovecot on Debian.

Then I tried using SMTP authentication according to this guide:

http://www.postfix.org/SASL_README.html

Unfortunately the following test tails:

telnet localhost 25
auth plain <base64 encoded usernaem/password>

We get a "535 5.78 Error: authentication failed:"

in var/log/mail.warn we habe a new line which is: "warning: localhost[127.0.0.1]: SASL PLAIN authentication failed:"

unfortunately it does not say what is wrong. Any ideas?

share|improve this question

1 Answer 1

It's really stupid. But here is the reason what went wrong:

we generated the base 64 string according to the documentation:

echo -ne '\000username\000password' | openssl base64

unfortunately our password started with a number. After changing the password to start with a character it worked fine!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.