Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running pfsense 2.0.3 nanobsd 4g i386 on virtualbox. VM configured with 4gb ram, there's 8 gb total on host system, with two net interfaces configured as host only. This will go on an SSD mini atx box, but for now I am just running on VM for learning pfsense.

I assigned interfaces, em0 to WAN, and em1 to LAN. From the windows host(hosting the VM) I brought up the browser and tried to connect to the LAN IP. I was intermettently getting timeouts and I would reboot the server or use the reboot web configurator option, and sometimes I could get the login screen but after logging in with default user/pass, I'd get a blank page. Absolutely no error messages or feedback of any kind. I typed password carefully, thinking maybe it was doing anonymous authentication, since according to their documentation provides a blank page by-design.

After many tries and reboots I finally got the wizard screen. I completed the wizard and the final page indicated it was going to redirect after a few moments, after a few minutes it redirected but failed to retrieve the next page. From there the web configurator again was not responsive, timing out. I rebooted and still same thing.

How do you troubleshoot something that gives you absolutely no feedback or error messages?

Any ideas about what might be wrong would be welcome, but primarily: How do I troubleshoot failures in the web configurator? Is there logs specific to the web configurator, or do I need to poke around in the web server logs, pfsense logs, etc.? Is there any documentation on directory structure that would help me find these? I've found from distribution to distribution, that each has it's own idea of where user programs, logs, etc are stored.

share|improve this question
add comment

1 Answer

It's unlikely you're having a web interface problem, almost certain it's a general network connectivity problem. Troubleshoot it as with any network problem. Can you ping it with no loss? You don't have the same IP in use somewhere else on your network? eg 192.168.1.1 on the VM and that IP is also the router on your physical network.

share|improve this answer
    
I didn't think it was a network problem since I'm able to sometimes get login screen and made it through the wizard once, but perhaps some settings I provided in the wizard mucked things up for the LAN interface. I was able to ping before the wizard, but I haven't tried after running the wizard, and haven't once gotten the login screen either. So that's likely the issue NOW. I may just reset settings and try the wizard again. As far as the login screen often going to a blank page issue, since that will probably reoccur after reset, is there any logs that would help me troubleshoot that? –  AaronLS Jul 2 '13 at 14:07
    
Was able to locate the log files after poking around for awhile and reading through clog manual. –  AaronLS Jul 3 '13 at 5:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.