Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just upgraded to Plesk 11.5.30 and found out that sending SMTP emails with php pear aren't working anymore with following error message:

mod_fcgid: stderr: PHP Fatal error: require_once(): 
Failed opening required 'Mail.php' 
(include_path='.:/usr/share/pear') 
in /var/www/vhosts/mydomain.com/httpdocs/check.php on line 4 

I know in the new Plesk 11.5 they changed the structure of all vhosts, but the strange thing is that require_once('System.php') placed into the same directory and file is working correctly with no errors and is returning bool(true).

Any hints where I could have a look with this mod_fcgid error when

require_once('System.php')

is working but

require_once('Mail.php')

isn't working?

share|improve this question
add comment

1 Answer

This seems to be a problem with your PHP installation. You could try to replace the default php base packages provided by Plesk.

I've positive experience with the REMI and EPEL repositories. These package repositories are not officially supported by CentOS, but they provide much more current versions of popular applications like PHP or MYSQL.

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
sudo rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

The Remi repository is disabled by default. You can change the settings in /etc/yum.epos.d/*.

yum clean all
yum update php mysql --enablerepo=remi

Don't forget to restart your services after the installation:

service httpd restart
service mysqld restart
service psa restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.