Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm attempting to install Nagios plugins on a Zimbra 8.0.2 server running CentOS 6.4, but have run into the following error when I run yum install nagios-plugins-all

Error: Package: nagios-plugins-mysql-1.4.15-2.el5.x86_64 (epel)
           Requires: libmysqlclient.so.15()(64bit)
Error: Package: nagios-plugins-pgsql-1.4.15-2.el5.x86_64 (epel)
           Requires: libpq.so.4()(64bit)
Error: Package: nagios-plugins-mysql-1.4.15-2.el5.x86_64 (epel)
           Requires: libmysqlclient.so.15(libmysqlclient_15)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

How can I install these libraries (libmysqlclient.so.15 & libpq.so.4)?

Will installing these libraries possibly break Zimbra?

share|improve this question
    
These should already be available in the base repositories. What changes have been made to them on this server? –  Michael Hampton Jun 29 '13 at 1:33
    
None that I'm aware of. I installed Zimbra 8.0.2 on a fresh CentOS 6.3 install (which has been updated to 6.4 now). And also installed nrpe. I've also installed the EPEL repo. –  Elijah Paul Jun 29 '13 at 1:39

1 Answer 1

Looks like I had to remove some cached packages:

Resolved this by running:

yum clean all

then

yum clean metadata

the latest version of nagios-plugins (1.4.16-5.el6.x86_64.rpm) was then available via the epel repo when running yum install nagios-plugins-all

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.