Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to download some videos from DefCon archive using wget but i'm getting this:

Unable to establish SSL connection.

I tried to use wget with --no-check-certificate but got the same result.
What is the problem?
How can I force wget to download the file?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I think the problem is at their end as I get the same issue when using a web browser, curl, wget and openssl client

~$ openssl s_client -connect media.defcon.org:443 CONNECTED(00000003) 15891:error:140790E5:SSL routines:SSL23_WRITE:ssl handshake failure:s23_lib.c:188:

share|improve this answer
    
Thanks; I reported the problem on their forum and they approved it; –  4r1y4n Jun 30 '13 at 16:46

Their torrent page works for me:


$ aria2c "https://www.defcon.org/html/torrent/DEF%20CON%2020%20hacker%20pyramid.torrent"
[#8c954b 0B/0B CN:1 DL:0B]
06/30 18:47:41 [NOTICE] Download complete: /home/dawud/downloads/DEF CON 20 hacker pyramid.torrent

06/30 18:47:41 [NOTICE] IPv4 DHT: listening on UDP port 6889

06/30 18:47:41 [NOTICE] IPv4 BitTorrent: listening on TCP port 6881

 *** Download Progress Summary as of Sun Jun 30 18:48:40 2013 ***
=================================================================================================================================================================================================================================

[#0f5992 16MiB/815MiB(2%) CN:2 SD:2 DL:287KiB ETA:47m24s]
share|improve this answer
    
Yes; it seems the problem only occure on the media subdomain. they approved the problem (see my comment on Epphus's answer) –  4r1y4n Jun 30 '13 at 17:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.