Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I raised OpenVPN on server for the first time. It worked fine until the server rebooted. The firewall configuration is unchanged. When I tcpdump from tun interface on the server, I always get TCP retransmissions on all TCP packets larger than a few bytes in Android.

Using a similar(read: same) configuration on my Linux box from where I'm posting this message now works just fine; no retransmissions, no loss.

It did work just fine before the server rebooted. What could possibly cause this? I already tried rebooting Android, it didn't help.

Client configuration, used on both Linux PC and Android tablet:

dev tun
client
remote 192.168.0.1
persist-key
persist-tun
nobind
pkcs12 user.p12
mssfix 1480
cipher AES-256-CBC
verb 3

1480 is below the mtu of uplink connection on server which is 1492.

I tried adding tun-mtu 1480 to Android but that didn't help either.

share|improve this question
    
final attempt: i set both 'tun-mtu' and 'mssfix' to 1380 on both server and client. surprisingly, it worked. SOLVED. –  anogaki Jun 30 '13 at 23:59
    
Please answer your question to preserve the solution for posterity. –  Deer Hunter Jul 1 '13 at 4:30

1 Answer 1

up vote 0 down vote accepted

final attempt: i set both 'tun-mtu' and 'mssfix' to 1380 on both server and client. surprisingly, it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.