Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My problem started yesterday night when I tried to change the my.cnf config on my ubuntu 12.04 x64 System. I simply tried to changed the bind-address parameter from 127.0.0.1 to 0.0.0.0.

A simple restart after a reboot gave this error:

stop: Unknown instance: 
start: Job failed to start

I tried to start mysql then by using 'mysqld' which outputs this:

130701 11:05:59 [Note] Plugin 'FEDERATED' is disabled.
mysqld: Table 'mysql.plugin' doesn't exist
130701 11:05:59 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
130701 11:05:59 InnoDB: The InnoDB memory heap is disabled
130701 11:05:59 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130701 11:05:59 InnoDB: Compressed tables use zlib 1.2.3.4
130701 11:05:59 InnoDB: Initializing buffer pool, size = 128.0M
130701 11:05:59 InnoDB: Completed initialization of buffer pool
130701 11:05:59 InnoDB: highest supported file format is Barracuda.
130701 11:05:59  InnoDB: Waiting for the background threads to start
130701 11:06:00 InnoDB: 5.5.31 started; log sequence number 1595675
130701 11:06:00 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130701 11:06:00 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
130701 11:06:00 [Note] Server socket created on IP: '127.0.0.1'.
130701 11:06:00 [ERROR] Can't start server : Bind on unix socket: Permission denied
130701 11:06:00 [ERROR] Do you already have another mysqld server running on socket: /var/run/mysqld/mysqld.sock ?
130701 11:06:00 [ERROR] Aborting

130701 11:06:00  InnoDB: Starting shutdown...
130701 11:06:00  InnoDB: Shutdown completed; log sequence number 1595675
130701 11:06:00 [Note] mysqld: Shutdown complete

Meanwhile I already tried to reinstall and purge the complete mysql package which results in another error which says that dpkg cant change the admins password.

While this error appeared another error came with it. When trying to install something new with apt, it always says 'fopen: permission denied' right after it tries to update my man-db.

This is my dmesg output:

[ 6879.687998] type=1400 audit(1372669683.397:36): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/mysqld" pid=9336 comm="apparmor_parser"
[ 6881.323215] init: mysql main process (9340) terminated with status 1
[ 6881.323316] init: mysql respawning too fast, stopped

Any help will be appreciated as this is a productive server which renders useless without mysql.

share|improve this question
    
[ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it. --> Did you do this? –  quanta Jul 1 '13 at 9:15
    
yep, I get another error saying that he can't write that table –  Evils Jul 1 '13 at 9:25
    
Please show us the exact error message. –  quanta Jul 1 '13 at 9:48
    
Looking for 'mysql' as: mysql Looking for 'mysqlcheck' as: mysqlcheck Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock' mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) when trying to connect FATAL ERROR: Upgrade failed –  Evils Jul 1 '13 at 10:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.