Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have few of profiles .pcf files , and I used them in order to automate the vpmclient connection VIA CLI command

  • I have WIN XP server

for example

       vpmclient connect "customor_alpha"

until now everything is ok

but I have problem with the last of my profiles - area1.pcf

the problem is when I type in CMD window the following ( to create VPN connection )

     vpmclient connect  "area1"

after 2 second CISCO window will pop up and ask for password , ( username already defined in window )

please advice what could be the problem , why I get the "CISCO PVN window" ? or maybe I have some in correct syntax in my .pcf file ,

I checked the .pcf file again and again and I couldn't find the problem ?

example of area1.pcf ( only example - not my real pcf )

 [main]
 Description=connection to TechPubs server
 Host=10.10.99.30
 AuthType=1
 GroupName=docusers
 GroupPwd=
 enc_GroupPwd=158E47893BDCD398BF863675204775622C49<SNIPPED>
 EnableISPConnect=0
 ISPConnectType=0
 ISPConnect=
 ISPCommand=
 Username=alice
 SaveUserPassword=0
 UserPassword=
 enc_UserPassword=
 NTDomain=
 EnableBackup=1
 BackupServer=Engineering1, Engineering2, Engineering 3, Engineering4
 EnableMSLogon=0
 MSLogonType=0
 EnableNat=1
 EnableLocalLAN=0
 TunnelingMode=0
 TCPTunnelingPort=10000
 CertStore=0
 CertName=
 CertPath=
 CertSubjectName
 SendCertChain=0
 VerifyCertDN=CN=”ID Cert”,OU*”Cisco”,ISSUER-CN!=”Entrust”,ISSURE-OU!*”wonderland”
 DHGroup=2
 PeerTimeOut=90
 ForceNetLogin=
share|improve this question

1 Answer 1

SaveUserPassword=0 
UserPassword=

Change the former to a 1 (1 equals true), put the password for the connection in the second. Save the file, then change the attributes to be read-only (this way the VPN client can't modify these lines).

This is something that I did at the last place for a connection to a client, so that the users connecting did not have to know the password.

NOTE: If the settings on the server do not allow for saved passwords, you may be required to enter it in every time, even after doing the above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.