Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have seen a couple of questions on ServerFault relating to installing ia32-libs on a 64bit machine but the solutions aren't working for me (I don't think any of these questions where for Wheezy specifically I'm not sure how to proceed);

root@server:/home/# apt-get install -f ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-i386
 php5 : Depends: libapache2-mod-php5 (>= 5.4.4-14+deb7u2) but it is not going to be installed or
                 libapache2-mod-php5filter (>= 5.4.4-14+deb7u2) but it is not going to be installed or
                 php5-cgi (>= 5.4.4-14+deb7u2) but it is not going to be installed or
                 php5-fpm (>= 5.4.4-14+deb7u2) but it is not going to be installed
 php5-mysql : Depends: phpapi-20100525
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


root@server:/home/# sudo apt-get install ia32-libs-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-i386:i386 : Depends: freeglut3:i386 (>= 2.6.0-1) but it is not going to be installed
                       Depends: lesstif2:i386 (>= 1:0.95.2-1) but it is not going to be installed
                       Depends: libacl1:i386 (>= 2.2.49-4) but it is not going to be installed
                       Depends: libasyncns0:i386 (>= 0.3-1.1) but it is not going to be installed
                       Depends: libattr1:i386 (>= 1:2.4.44-2) but it is not going to be installed
                       Depends: libaudio2:i386 (>= 1.9.2-4) but it is not going to be installed
                       Depends: libaudiofile1:i386 (>= 0.2.6-8) but it is not going to be installed
                       Depends: libavahi-client3:i386 (>= 0.6.27-2+squeeze1) but it is not going to be installed
                       Depends: libavahi-common3:i386 (>= 0.6.27-2+squeeze1) but it is not going to be installed
                       Depends: libbsd0:i386 (>= 0.2.0-1) but it is not going to be installed
                       Depends: libcap2:i386 (>= 1:2.19-3) but it is not going to be installed
                       Depends: libcomerr2:i386 (>= 1.41.12-4stable1) but it is not going to be installed
                       Depends: libcups2:i386 (>= 1.4.4-7+squeeze1) but it is not going to be installed
                       Depends: libcurl3:i386 (>= 7.21.0-2) but it is not going to be installed
                       Depends: libdbus-1-3:i386 (>= 1.2.24-4+squeeze1) but it is not going to be installed
                       Depends: libdirectfb-1.2-9:i386 (>= 1.2.10.0-4) but it is not going to be installed
                       Depends: libdrm-intel1:i386 (>= 2.4.21-1~squeeze3) but it is not going to be installed
                       Depends: libdrm-radeon1:i386 (>= 2.4.21-1~squeeze3) but it is not going to be installed
                       Depends: libdrm2:i386 (>= 2.4.21-1~squeeze3) but it is not going to be installed
                       Depends: libedit2:i386 (>= 2.11-20080614-2) but it is not going to be installed
                       Depends: libesd0:i386 (>= 0.2.41-8) but it is not going to be installed
                       Depends: libexif12:i386 (>= 0.6.19-1) but it is not going to be installed
                       Depends: libexpat1:i386 (>= 2.0.1-7) but it is not going to be installed
                       Depends: libflac8:i386 (>= 1.2.1-2+b1) but it is not going to be installed
                       Depends: libfltk1.1:i386 (>= 1.1.10-2+b1) but it is not going to be installed
                       Depends: libfontconfig1:i386 (>= 2.8.0-2.1) but it is not going to be installed
                       Depends: libfreetype6:i386 (>= 2.4.2-2.1+squeeze3) but it is not going to be installed
                       Depends: libgcrypt11:i386 (>= 1.4.5-2) but it is not going to be installed
                       Depends: libgdbm3:i386 (>= 1.8.3-9) but it is not going to be installed
                       Depends: libgl1-mesa-dri:i386 (>= 7.7.1-5) but it is not going to be installed
                       Depends: libgl1-mesa-glx:i386 (>= 7.7.1-5) but it is not going to be installed
                       Depends: libglu1-mesa:i386 (>= 7.7.1-5) but it is not going to be installed
                       Depends: libgnutls26:i386 (>= 2.8.6-1) but it is not going to be installed
                       Depends: libgpg-error0:i386 (>= 1.6-1) but it is not going to be installed
                       Depends: libgphoto2-2:i386 (>= 2.4.6-3) but it is not going to be installed
                       Depends: libgphoto2-port0:i386 (>= 2.4.6-3) but it is not going to be installed
                       Depends: libgssapi-krb5-2:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: libice6:i386 (>= 2:1.0.6-2) but it is not going to be installed
                       Depends: libidn11:i386 (>= 1.15-2) but it is not going to be installed
                       Depends: libieee1284-3:i386 (>= 0.2.11-6) but it is not going to be installed
                       Depends: libjack-jackd2-0:i386 (>= 1.9.5~dfsg-14) but it is not going to be installed or
                                libjack0:i386 (>= 1:0.118+svn3796-7) but it is not going to be installed
                       Depends: libjpeg62:i386 (>= 6b1-1) but it is not going to be installed
                       Depends: libjpeg8:i386 (>= 8b-1) but it is not going to be installed
                       Depends: libk5crypto3:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: libkeyutils1:i386 (>= 1.4-1) but it is not going to be installed
                       Depends: libkrb5-3:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: libkrb5support0:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: liblcms1:i386 (>= 1.18.dfsg-1.2+b3) but it is not going to be installed
                       Depends: libltdl7:i386 (>= 2.2.6b-2) but it is not going to be installed
                       Depends: liblzo2-2:i386 (>= 2.03-2) but it is not going to be installed
                       Depends: libmpg123-0:i386 (>= 1.12.1-3) but it is not going to be installed
                       Depends: libnspr4-0d:i386 (>= 4.8.6-1) but it is not going to be installed
                       Depends: libnss3-1d:i386 (>= 3.12.8-1+squeeze4) but it is not going to be installed
                       Depends: libogg0:i386 (>= 1.2.0~dfsg-1) but it is not going to be installed
                       Depends: libopenal1:i386 (>= 1:1.12.854-2) but it is not going to be installed
                       Depends: libpam0g:i386 (>= 1.1.1-6.1+squeeze1) but it is not going to be installed
                       Depends: libpng12-0:i386 (>= 1.2.44-1+squeeze1) but it is not going to be installed
                       Depends: libpopt0:i386 (>= 1.16-1) but it is not going to be installed
                       Depends: libpulse0:i386 (>= 0.9.21-3+squeeze1) but it is not going to be installed
                       Depends: libsamplerate0:i386 (>= 0.1.7-3) but it is not going to be installed
                       Depends: libsane:i386 (>= 1.0.21-9) but it is not going to be installed
                       Depends: libsasl2-2:i386 (>= 2.1.23.dfsg1-7) but it is not going to be installed
                       Depends: libsdl1.2debian:i386 (>= 1.2.15) but it is not going to be installed
                       Depends: libselinux1:i386 (>= 2.0.96-1) but it is not going to be installed
                       Depends: libsigc++-2.0-0c2a:i386 (>= 2.2.4.2-1) but it is not going to be installed
                       Depends: libsm6:i386 (>= 2:1.1.1-1) but it is not going to be installed
                       Depends: libsndfile1:i386 (>= 1.0.21-3+squeeze1) but it is not going to be installed
                       Depends: libsqlite3-0:i386 (>= 3.7.3-1) but it is not going to be installed
                       Depends: libssh2-1:i386 (>= 1.2.6-1) but it is not going to be installed
                       Depends: libssl1.0.0:i386 (>= 1) but it is not going to be installed
                       Depends: libstdc++5:i386 (>= 1:3.3.6-20) but it is not going to be installed
                       Depends: libsvga1:i386 (>= 1:1.4.3-29) but it is not going to be installed
                       Depends: libsysfs2:i386 (>= 2.1.0+repack-1) but it is not going to be installed
                       Depends: libtasn1-3:i386 (>= 2.7-1) but it is not going to be installed
                       Depends: libtdb1:i386 (>= 1.2.1-2+b1) but it is not going to be installed
                       Depends: libtiff4:i386 (>= 3.9.4-5+squeeze3) but it is not going to be installed
                       Depends: libts-0.0-0:i386 (>= 1.0-7) but it is not going to be installed
                       Depends: libusb-0.1-4:i386 (>= 2:0.1.12-16) but it is not going to be installed
                       Depends: libuuid1:i386 (>= 2.17.2-9) but it is not going to be installed
                       Depends: libvorbis0a:i386 (>= 1.3.1-1) but it is not going to be installed
                       Depends: libvorbisenc2:i386 (>= 1.3.1-1) but it is not going to be installed
                       Depends: libvorbisfile3:i386 (>= 1.3.1-1) but it is not going to be installed
                       Depends: libwrap0:i386 (>= 7.6.q-19) but it is not going to be installed
                       Depends: libx11-6:i386 (>= 2:1.3.3-4) but it is not going to be installed
                       Depends: libx86-1:i386 (>= 1.1+ds1-6) but it is not going to be installed
                       Depends: libxau6:i386 (>= 1:1.0.6-1) but it is not going to be installed
                       Depends: libxaw7:i386 (>= 2:1.0.7-1) but it is not going to be installed
                       Depends: libxcb-render-util0:i386 (>= 0.3.6-1) but it is not going to be installed
                       Depends: libxcb-render0:i386 (>= 1.6-1) but it is not going to be installed
                       Depends: libxcb1:i386 (>= 1.6-1) but it is not going to be installed
                       Depends: libxcomposite1:i386 (>= 1:0.4.2-1) but it is not going to be installed
                       Depends: libxcursor1:i386 (>= 1:1.1.10-2) but it is not going to be installed
                       Depends: libxdamage1:i386 (>= 1:1.1.3-1) but it is not going to be installed
                       Depends: libxdmcp6:i386 (>= 1:1.0.3-2) but it is not going to be installed
                       Depends: libxext6:i386 (>= 2:1.1.2-1) but it is not going to be installed
                       Depends: libxfixes3:i386 (>= 1:4.0.5-1) but it is not going to be installed
                       Depends: libxft2:i386 (>= 2.1.14-2) but it is not going to be installed
                       Depends: libxi6:i386 (>= 2:1.3-6) but it is not going to be installed
                       Depends: libxinerama1:i386 (>= 2:1.1-3) but it is not going to be installed
                       Depends: libxml2:i386 (>= 2.7.8.dfsg-2+squeeze1) but it is not going to be installed
                       Depends: libxmu6:i386 (>= 2:1.0.5-2) but it is not going to be installed
                       Depends: libxmuu1:i386 (>= 2:1.0.5-2) but it is not going to be installed
                       Depends: libxp6:i386 (>= 1:1.0.0.xsf1-2) but it is not going to be installed
                       Depends: libxpm4:i386 (>= 1:3.5.8-1) but it is not going to be installed
                       Depends: libxrandr2:i386 (>= 2:1.3.0-3) but it is not going to be installed
                       Depends: libxrender1:i386 (>= 1:0.9.6-1) but it is not going to be installed
                       Depends: libxslt1.1:i386 (>= 1.1.26-6) but it is not going to be installed
                       Depends: libxss1:i386 (>= 1:1.2.0-2) but it is not going to be installed
                       Depends: libxt6:i386 (>= 1:1.0.7-1) but it is not going to be installed
                       Depends: libxtst6:i386 (>= 2:1.1.0-3) but it is not going to be installed
                       Depends: libxv1:i386 (>= 2:1.0.5-1) but it is not going to be installed
                       Depends: libxxf86vm1:i386 (>= 1:1.1.0-2) but it is not going to be installed
                       Depends: odbcinst1debian2:i386 (>= 2.2.14p2-1) but it is not going to be installed
                       Depends: libodbc1:i386 but it is not going to be installed
                       Depends: xaw3dg:i386 (>= 1.5+E-18) but it is not going to be installed
 php5 : Depends: libapache2-mod-php5 (>= 5.4.4-14+deb7u2) but it is not going to be installed or
                 libapache2-mod-php5filter (>= 5.4.4-14+deb7u2) but it is not going to be installed or
                 php5-cgi (>= 5.4.4-14+deb7u2) but it is not going to be installed or
                 php5-fpm (>= 5.4.4-14+deb7u2) but it is not going to be installed
 php5-mysql : Depends: phpapi-20100525
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

root@server:/home/# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.1 (wheezy)
Release:    7.1
Codename:   wheezy

root@server:/home/# uname -a
Linux servername 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux

root@server:/home/# cat /etc/apt/sources.list | grep -v \# | grep -v ^$
deb http://mirror.bytemark.co.uk/debian/ wheezy main contrib  non-free
deb-src http://mirror.bytemark.co.uk/debian/ wheezy main contrib  non-free
deb http://ftp.us.debian.org/debian stable main contrib non-free

root@server:/home# arch
x86_64

root@server:/home/# dpkg --print-architecture
amd64

root@server:/home/# dpkg --print-foreign-architectures
i386

root@server:/home/# cat /var/lib//dpkg/arch 
amd64
i386

root@server:/home/# dpkg -l libc6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                              Version               Architecture          Description
+++-=================================-=====================-=====================-=======================================================================
ii  libc6:amd64                       2.17-6                amd64                 Embedded GNU C Library: Shared libraries


root@server:/home/# apt-get install libc6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@server:/home/# sudo apt-get install libgcc1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not going to be installed
                PreDepends: multiarch-support:i386
E: Unable to correct problems, you have held broken packages.
share|improve this question
1  
It looks like you have a broken PHP install. I'd fix that first. –  Nathan C Jul 1 '13 at 11:22
    
I suspect you may find your answer in wiki.debian.org/Multiarch/HOWTO –  adric Jul 1 '13 at 12:15
1  
Some packages may really be on hold. What's the output of dpkg --get-selections | awk '$2!="purge" && $2!="install" && $2!="deinstall" {print}'? –  eppesuig Jul 1 '13 at 13:13
    
@eppesuig That command produces no output at all, which I assume is a good thing really! –  jwbensley Jul 2 '13 at 9:13
1  
@javano, then I think you should really clarify why you need to install ia32-libs since it should not be usefull at all on Debian 7 because of the multiarch support. If you need to install an i386 Debian package, just use apt-get install packagename:i386 and it should work. If you need to install a non Debian package than, check what 32 bits library it needs, and install each of them using apt-get and appending the :i386 at the end. I saw that you cannot install libc6:i386: are you sure you did apt-get update after adding i386 architecture? –  eppesuig Jul 2 '13 at 10:10
add comment

1 Answer

up vote 2 down vote accepted

Short answer: don't install ia32-libs as that is not how it works anymore. You need to add i386 as an architecture and install libc6:i386 and other required packages to complete whatever install task you are working on. If you give us more detail we can help more.

For example I had to do that to get Hopper (32bit) running on Kali (based on Debian testing) so I now have libc6 (and many other libs) twice.

bsk@kali-bebo:~/racket$ arch
x86_64

bsk@kali-bebo:~/racket$ dpkg -l libc6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  libc6:amd64    2.13-38      amd64        Embedded GNU C Library: Shared li
ii  libc6:i386     2.13-38      i386         Embedded GNU C Library: Shared li

The details of Debian's multi-arch system are on Debian's wiki here.

share|improve this answer
    
Thanks for the answer Adric! I have already enabled multi-arch support as I put in my original questions. I have added some additional output to it, as I can't install libc6:i386 as per your suggestion either. –  jwbensley Jul 2 '13 at 9:14
    
Ah okay. Thanks for the extra console output. Did you look in your apt configs to see what you might have pinned or held? This error is still pretty troubling: "E: Unable to correct problems, you have held broken packages.". And what package are you trying to install that needs 32 bit libs, if you can share that? –  adric Jul 2 '13 at 11:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.