Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just created virtual host:

<VirtualHost myvirtualhost:80>
ServerAdmin webmaster@myvirtualhost
ServerName myvirtualhost

DocumentRoot /home/myname/sites/public_html

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>


<Directory /home/myname/sites/public_html/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

It works, but it cant read .htacces file in public_html:

DirectoryIndex otherindex.php

I tried change all AllowOverride to All, but I get 500 error. How can I fix this ? thanks.

share|improve this question
add comment

1 Answer

Is mod_dir activated ?

http://httpd.apache.org/docs/2.2/mod/mod_dir.html#directoryindex

You also need to be broader in your allowoverride directive, you should at least put "AllowOverride Indexes"

http://httpd.apache.org/docs/current/fr/mod/core.html#allowoverride

share|improve this answer
    
yes my mod_dir is active, I tried with only indexes , and everthing I do with AllowOverride, I always get Internal Server error –  Charlie Jul 1 '13 at 15:59
    
What is your error.log saying about these internal server errors ? –  user2299634 Jul 1 '13 at 16:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.