Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install KVM on Ubuntu 12.04 server. We have multiple nic on this server of which we primarily use eth0. The server network runs fine(i'm able to ping gateway, ping dns server and ping servers on internet) with eth0

/etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
      address 192.168.22.194
      netmask 255.255.255.0
      network 192.168.22.0
      broadcast 192.168.22.255
      gateway 192.168.22.1
      dns-nameservers 10.71.130.58 10.71.130.60
      dns-search test.local

I installed bridge-utils and configured br0 as below

/etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto br0
iface br0 inet static
      address 192.168.22.194
      netmask 255.255.255.0
      network 192.168.22.0
      broadcast 192.168.22.255
      gateway 192.168.22.1
      dns-nameservers 10.71.130.58 10.71.130.60
      dns-search test.local
      bridge_ports eth0
      bridge_fd 9
      bridge_hello 2
      bridge_maxage 12
      bridge_stp off

Post which i'm able to ping servers on the same ip range 192.168.22.2-254 except for 192.168.22.1 (which is the gateway) also i'm not able to ping any other servers. I'm not able to ping this machine from network.

The output for route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags   Metric  Ref     Use Iface
0.0.0.0         192.168.22.1    0.0.0.0         UG      100     0       0   br0
192.168.22.0    0.0.0.0         255.255.255.0   U       0       0       0   br0
192.168.122.0   0.0.0.0         255.255.255.0   U       0       0       0   virbr0

I've been struggling with this issue for past 5 days, would be of help if anyone can point me in the right direction to fix this issue. Thanks in advance

Update:

    root@cognos:/etc/network# brctl show
bridge name     bridge id               STP enabled     interfaces
br0             8000.984be17537a8       no              eth0
virbr0          8000.000000000000       yes


root@cognos:/etc/network# tracepath 192.168.22.1
1: server1.test.local                   0.081ms pmtu 1500
1: no reply
2: no reply
3: no reply
4: no reply
.
.
.
31: no reply
    Too many hops: pmtu 1500
    Resume: pmtu 1500

root@cognos:/etc/network# ip route show dev br0
default via 192.168.22.1 metric 100
192.168.22.0/24 proto kernel scope link src 192.168.22.194

root@cognos:/etc/network# ip addr show dev br0
9: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisk noqueue state UP
    link/ether 98:4b:e1:75:37:a8 brd ff:ff:ff:ff:ff:ff:ff
        inet 192.168.22.194/24 brd 192.168.22.255 scope global br0
    inet6 fe80::9a4b:e1ff:fe75:37a8/64 scope link
       valid_lft forever preferred_lft forever

Update 2: ifconfig output: http://tinypic.com/r/2v8mkhk/5

Update 3: I tried assigning static ip to eth0 and assign bridge port to eth1. The ip addr now shows br0 is DOWN and could not bring it up.

root@cognos:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.22.194
netmask 255.255.255.0
network 192.168.22.0
broadcast 192.168.22.255
gateway 192.168.22.1
dns-nameservers 10.71.130.58 10.71.130.60
dns-search test.local

auto eth1
iface eth1 inet manual

auto br0
iface br0 inet static
        address 192.168.22.24
        netmask 255.255.255.0
        network 192.168.22.0
        broadcast 192.168.22.255
        gateway 192.168.22.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 10.71.130.58 10.71.130.60
        dns-search test.local
        bridge_ports eth1
        bridge_fd 9
        bridge_hello 2
        bridge_maxage 12
        bridge_stp off


root@cognos:~# ip addr show dev eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 98:4b:e1:75:37:a8 brd ff:ff:ff:ff:ff:ff
    inet 192.168.22.194/24 brd 192.168.22.255 scope global eth0

root@cognos:~# ip addr show dev br0
6: br0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN
    link/ether 98:4b:e1:75:37:aa brd ff:ff:ff:ff:ff:ff
    inet 192.168.22.24/24 brd 192.168.22.255 scope global br0

root@cognos:~# ifup br0

Waiting for br0 to get ready (MAXWAIT is 20 seconds).
RTNETLINK answers: File exists
Failed to bring up br0.

root@cognos:~# ifdown br0
ifdown: interface br0 not configured

ifconfig details:

root@cognos:~# ifconfig
br0       Link encap:Ethernet  HWaddr 98:4b:e1:75:37:aa
          inet addr:192.168.22.24  Bcast:192.168.22.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 98:4b:e1:75:37:a8
          inet addr:192.168.22.194  Bcast:192.168.22.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:28476 errors:0 dropped:47 overruns:0 frame:0
          TX packets:223 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4341366 (4.3 MB)  TX bytes:26708 (26.7 KB)

eth1      Link encap:Ethernet  HWaddr 98:4b:e1:75:37:aa
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:158 errors:0 dropped:0 overruns:0 frame:0
          TX packets:158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:13646 (13.6 KB)  TX bytes:13646 (13.6 KB)

virbr0    Link encap:Ethernet  HWaddr c2:07:2d:20:f7:05
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
share|improve this question
    
Does your router work :)? Could you also post the output of brctl show and perhaps some traceroutes/tracepaths? –  Halfgaar Jul 2 '13 at 11:49
    
oh, and could you also post the network config of the router? Perhaps it has a different subnet mask or something. –  Halfgaar Jul 2 '13 at 11:54
    
Hi @Halfgaar, thanks for your reply. I've updated the ticket with brctl show and tracepaths –  Ara Jul 2 '13 at 12:39
    
and what about the gateway's network config? –  Halfgaar Jul 2 '13 at 12:52
    
hi @Halfgaar, i've requested that info from my networking team and am waiting from them to revert. If there is an issue with gateway's network config, will it work with eth0? –  Ara Jul 3 '13 at 14:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.