Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up a vsftpd server (in centos) which allows anonymous READ/WRITE.Here is my configuration

anonymous_enable=YES
local_enable=YES
write_enable=YES
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/xferlog
xferlog_std_format=YES
ftpd_banner=Welcome to blah FTP service.
listen=YES
pam_service_name=vsftpd
userlist_enable=NO
tcp_wrappers=YES
anon_root=/var/ftp/

In my /var/ftp/ folder. The permission is set to 777 which is owned by root. When i tried put /file/path/here.txt I am getting 553 error. Are there any setting that i am missing?

share|improve this question

1 Answer 1

SELinux context must be public_content_rw_t, set it with chcon -t public_content_rw_t /var/ftp

share|improve this answer
    
Thanks! my SELinux is set to disabled. –  user1817081 Jul 2 '13 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.