Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ok so I am a bit new at all this.

I was trying to get php and apache2 running on my localhost and I don't seem to be able to get it to work.

I keep getting this message when inputting localhost into chrome on my machine:

Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

I have found and will paste the error log below:

[Wed Jul 03 12:11:57 2013] [notice] caught SIGTERM, shutting down
[Wed Jul 03 12:12:02 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
httpd: Could not reliably determine the server's fully qualified domain name, using Orion.local for ServerName
[Wed Jul 03 12:12:02 2013] [notice] Digest: generating secret for digest authentication ...
[Wed Jul 03 12:12:02 2013] [notice] Digest: done
[Wed Jul 03 12:12:02 2013] [notice] Apache/2.2.22 (Unix) DAV/2 mod_ssl/2.2.22 OpenSSL/0.9.8x configured -- resuming normal operations
[Wed Jul 03 12:32:28 2013] [notice] caught SIGTERM, shutting down
[Wed Jul 03 12:32:28 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
httpd: Could not reliably determine the server's fully qualified domain name, using Orion.local for ServerName
[Wed Jul 03 12:32:28 2013] [notice] Digest: generating secret for digest authentication ...
[Wed Jul 03 12:32:28 2013] [notice] Digest: done
[Wed Jul 03 12:32:28 2013] [notice] Apache/2.2.22 (Unix) DAV/2 mod_ssl/2.2.22 OpenSSL/0.9.8x configured -- resuming normal operations
[Wed Jul 03 13:04:19 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:04:19 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:04:19 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:04:24 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:04:24 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:04:37 2013] [notice] caught SIGTERM, shutting down
[Wed Jul 03 13:04:38 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
httpd: Could not reliably determine the server's fully qualified domain name, using Orion.local for ServerName
[Wed Jul 03 13:04:38 2013] [notice] Digest: generating secret for digest authentication ...
[Wed Jul 03 13:04:38 2013] [notice] Digest: done
[Wed Jul 03 13:04:38 2013] [notice] Apache/2.2.22 (Unix) DAV/2 mod_ssl/2.2.22 OpenSSL/0.9.8x configured -- resuming normal operations
[Wed Jul 03 13:04:41 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:04:41 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:04:41 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:04:43 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:04:43 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:06:31 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:06:31 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:06:32 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:09:08 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:09:08 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:09:08 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:10:08 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:10:08 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:10:08 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:21:17 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:21:17 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:21:18 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:35:20 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:35:20 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:35:21 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:35:21 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:36:32 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:36:32 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:36:32 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:37:01 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:37:02 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:40:19 2013] [notice] caught SIGTERM, shutting down
[Wed Jul 03 13:40:20 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
httpd: Could not reliably determine the server's fully qualified domain name, using Orion.local for ServerName
[Wed Jul 03 13:40:20 2013] [notice] Digest: generating secret for digest authentication ...
[Wed Jul 03 13:40:20 2013] [notice] Digest: done
[Wed Jul 03 13:40:20 2013] [notice] Apache/2.2.22 (Unix) DAV/2 mod_ssl/2.2.22 OpenSSL/0.9.8x configured -- resuming normal operations
[Wed Jul 03 13:40:24 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:40:24 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:40:25 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:40:25 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:44:45 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:44:45 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:44:46 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:50:15 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 13:50:15 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 13:50:16 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:50:22 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 13:50:23 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:08:34 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 14:08:34 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 14:08:35 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:08:35 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:26:37 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 14:26:37 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 14:26:40 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:26:40 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:29:51 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 14:29:51 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 14:29:52 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:31:19 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 14:31:19 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 14:31:19 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:32:50 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 14:32:50 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 14:32:50 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:33:06 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:33:06 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:33:38 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:33:39 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:34:49 2013] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:20559 (localhost) failed
[Wed Jul 03 14:34:49 2013] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Jul 03 14:34:50 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:34:52 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:34:54 2013] [error] proxy: HTTP: disabled connection for (localhost)
[Wed Jul 03 14:34:55 2013] [error] proxy: HTTP: disabled connection for (localhost)

Not exactly sure what to do with this and I would really like to get up and running.

Thanks for help in advance.

share|improve this question

1 Answer 1

Apache is trying to connect to an upstream proxy at fe80::1 port 20559, but there is no service running at that address/port. Since no service is running, Apache gets Connection refused and returns a 503 error.

To resolve the issue, either start the service, or use the correct IP address/port number, as applicable. (It's unlikely that fe80::1 is the correct address.)

share|improve this answer
    
MACs have fe80::1%lo0 localhost as an entry in their hosts file so it could be a valid address. –  Iain Jul 3 '13 at 18:49
    
He'd have to put the %lo0 on the end, then. It seems to be missing. Though I would consider that broken; localhost is ::1 and ::1 is localhost... –  Michael Hampton Jul 3 '13 at 18:50
    
Ok so I have had a look at my hosts file as Iain has said and this is what is showing: 127.0.0.1 localhost 255.255.255.255 broadcasthost ::1 localhost fe80::1%lo0 localhost I don't really know what to do here to resolve the issue so I would really like some help. –  John E Jul 8 '13 at 12:23
    
You're looking at the wrong file. It's your Apache configuration you need to be looking at. –  Michael Hampton Jul 8 '13 at 15:58
    
Ok Michael I have had a look at my config file and there doesn't seem to be anything in there too sinister that I can figure out. So what I have done is uploaded a copy of it into a Gist on GitHub. I would really appreciate it if you would have a look for me and see if you think there is anything amiss. gist.github.com/johnend/5966532 –  John E Jul 10 '13 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.