Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hi all,
I am having some problems getting a Xen bridge up in Ubuntu precise with Xen.
I created a first bridge on eth1 with no problems, but the exact same process for eth2 yields the following problems:

/etc/network/interfaces
auto xenbr1
iface xenbr1inet manual
bridge_ports eth1
bridge_fd 9
bridge_hello 2
bridge_maxage 12
bridge_stp off

auto xenbr2
iface xenbr2 inet manual
bridge_ports eth2
bridge_fd 9
bridge_hello 2
bridge_maxage 12
bridge_stp off


ifup xenbr2
Waiting for xenbr2 to get ready (MAXWAIT is 20 seconds).
ssh stop/waiting
ssh start/running, process 10377
(Takes quite a while)


dmesg | tail
[108513.254296] device eth2 entered promiscuous mode
[108513.390125] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[108513.410895] IPv6: ADDRCONF(NETDEV_UP): xenbr2: link is not ready


ifconfig eth2
eth2 Link encap:Ethernet direcciónHW 00:26:b9:46:61:1d

ACTIVO DIFUSIÓN MULTICAST MTU:1500 Métrica:1
Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupción:16


I have tried adding the following lines to sysctl:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

No joy there...

Does anyone know where I am messing up?
Cheers for the help!

share|improve this question
    
Did you plug in a network cable? –  Michael Hampton Jul 4 '13 at 20:49

2 Answers 2

Apparently that switch does not work (with today kernels). You have to disable ipv6 for every single interface individually.

share|improve this answer
    
net.ipv6.conf.default.disable_ipv6 = 1<br> net.ipv6.conf.lo.disable_ipv6 = 1<br> net.ipv6.conf.eth2.disable_ipv6 = 1<br> No joy there either –  user2284355 Jul 4 '13 at 18:14
up vote 0 down vote accepted

It was a driver issue.
Compiled ethernet drivers from compat-drivers and it worked.
https://backports.wiki.kernel.org/index.php/Releases

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.