Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a BackupPC server that is supposed to be backing up a Lotus Domino 9 server, both on Ubuntu 12.04 64-bit with rsync 3.0.9.

Our Domino server is set to archive e-mail messages that are older that 12 months, and I have performed this archiving manually once, resulting in a number of notesdata/archive/a_user.nsf files with sizes between 50 MB and 2 GB or so. These files do not change in file size as of right now, but their modification time do change each day due to Domino running fix-ups on them.

My problem is that BackupPC is backing up these files in full each day, despite running an incremental backup. I have tried the rsync/xfer option --size-only without result. Maybe this is due to the files being altered in some way when running fix-up in Domino, without it showing up as a files size change? For example, if Domino runs a fix-up on the files it might insert a new timestamp inside the nsf causing some sort of checksum failure for rsync/xfer.

The question is, am I using --size-only right or is there a different option for rsync/xfer/backuppc availible to me? If not then I'd have to change the way Domino performs these fix-ups (assuming that's possible).

Thanks in advance for any input.

share|improve this question
What do a md5sum/sha256sum on the .nsf files (live and backup) show? Are the .nsf files binary? – blau Jul 5 '13 at 8:12
Did you check the rsync faq rsync recopies the same files? – blau Jul 5 '13 at 8:19
Thanks blau, it was the --times option missing. I must have removed it in a previous attempt to solve the mystery, because it exists on other machines. – Johan B Jul 8 '13 at 7:03
up vote 0 down vote accepted

User blau pointed me to the rsync FAQ on why the same files are being copied over and over. Turns out it was the --times option missing from the original BackupPC xfer command.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.