Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I sit at work every thing works fine.

But when I am at home, I cant connect with a trusted connection to any sql server at work.

I have tried different versions of Windows (XP, Vista and Windows 7).

The VPN connection is a software connection in windows, connecting to an ISA Server.

Is there any way to make a login trusted, even tough I was not originaly done against the domain?

1) Login to windows (no access to the domain) 2) Create VPN connection (access to the domain) 3) run "something" to make the login trusted in the domain.

Thanks

share|improve this question

2 Answers 2

If the computer is a member of the domain, then yes. If the computer is not a member of the domain, sort of. Change your username (or create a work account on the computer) so that the local username matches your username on the domain. Set the password on that account to match the password on the domain. Log in with that account and you "should" be able to create a Windows Auth connection to the server.

The more reliable option would be to add the machine to the domain, but if this is your home machine you probably don't want to do that.

share|improve this answer
    
Hey Its a work computer (laptop), and it is a member of the coporate domain. If I run a gpupdate at work it works great. If I run gpupdate at home with the VPN connection I get the following error: The processing of Group Policy failed. Windows attempted to read the file \\xxx\sysvol\xxx\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini from a domain controller and was not successful. Group Policy settings may not be applied until this event is resolved. This issue may be transient and could be caused by one or more of the following: –  Morten Lyhr Aug 10 '09 at 18:04
    
a) Name Resolution/Network Connectivity to the current domain controller. b) File Replication Service Latency (a file created on another domain controller has not replicated to the current domain controller). c) The Distributed File System (DFS) client has been disabled. Computer Policy update has completed successfully. To diagnose the failure, review the event log or run GPRESULT /H GPReport.html f rom the command line to access information about Group Policy results. –  Morten Lyhr Aug 10 '09 at 18:05
    
If you are logging into a domain account and your password on the domain hasn't been changed with the laptop having an old password it should work find. That's how I connect to work every day from home (I work from home full time) just without ISA in the middle. Are you able to ping the network resources? Can you ping AD DNS name? –  mrdenny Aug 10 '09 at 19:45

I figured it out.

The VPN user is not part of the windows domain, and after the vpn login the non-domain account was used against the domain.

In windows 7, In the windows credentials manager. I edited "*Sesssion" to be my domain account after the VPN login. Now everything works.

share|improve this answer
    
Thanks, I had the same problem and this worked for me. But it seems to be something I need to do each time I log on to VPN. Do you know of any way to make this persistent, so I don't need to do it manually each time ? –  driis Jan 20 '11 at 17:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.