Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been having an issue to send mails, mostly to domains using Outlook.com as mailserver.

For example:

Jul  5 15:38:20 vm-dns-mail postfix/smtp[29249]: B6A3A20113E: to=<xxxx.duchene@grassvalley.com>, relay=none, delay=189023, delays=189019/0.05/4/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=grassvalley-com.mail.eo.outlook.com type=AAAA: Host not found, try again)

But it has a correct MX record:

vm-dns-mail ~/bin # dig mx grassvalley.com
[...]
;; ANSWER SECTION:
grassvalley.com.        7362    IN      MX      5 grassvalley-com.mail.eo.outlook.com.

And I can telnet to it:

vm-dns-mail ~/bin # telnet grassvalley-com.mail.eo.outlook.com 25
EHLO
Trying 207.46.163.30...
Connected to grassvalley-com.mail.eo.outlook.com.
Escape character is '^]'.
220 CO9EHSMHS019.bigfish.com Microsoft ESMTP MAIL Service ready at Fri, 5 Jul 2013 19:45:12 +0000
250-CO9EHSMHS019.bigfish.com Hello [85.12.6.130]
250-SIZE 157286400
250-PIPELINING
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH
250-8BITMIME
250-BINARYMIME
250 CHUNKING

I thought it was an IPV6 issue, as this VM is unable to connect to IPV6. So I added this line to main.cf:

inet_protocols = ipv4

But it merely changed the issue to this:

Jul  5 21:41:38 vm-dns-mail postfix/smtp[30661]: C1102201234: to=<xxxxx@cjp.be>, relay=none, delay=2, delays=0.01/0/2/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=cjp-be.mail.eo.outlook.com type=A: Host not found, try again)

What could cause this, rather annoying, problem?

share|improve this question
    
seems like a name resolution issue, check your DNS resolver on that machine. –  topdog Jul 5 '13 at 19:54
    
I was actually just looking into that, and something rather stupid seems to have fixed it... "options timeout:1 attempts:1" in resolv.conf –  Tuinslak Jul 5 '13 at 20:01
add comment

1 Answer

up vote 1 down vote accepted

This is what resolv.conf looked like in Postfix's chroot.

vm-dns-mail /var/spool/postfix/etc # cat resolv.conf 
options timeout:1 attempts:1
nameserver 8.8.8.8
nameserver 8.8.4.4

Removing options timeout:1 attempts:1 seems to have fixed it. Keeping that line, but adding other DNS servers (opendns for example) seems to also fix it...

I'll keep running some tests and monitor it.

share|improve this answer
1  
You are using Google's nameservers. If you are running a mailserver, it's better to set up your own nameserver on your system. –  edwardmp Jul 5 '13 at 22:48
    
What would be the difference ? –  Tuinslak Jul 6 '13 at 7:29
    
Most DNS based services have daily query limits meaning that if you use Google's name servers you will get locked out. The second issue is do you want this creepy company spying on your mail traffic as well ? –  topdog Dec 31 '13 at 18:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.