Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have very strange problem. In a office computer network with about 100 PCs with mixed Windows XP SP3, Windows 7 and some Windows Server 2008 R2, I've decided to upgrade the network from Fast Ethernet to Gigabit by changing the main 100Mbps switch (a TP-Link) with a 1Gbps switch (ZyXEL GS1910-48). There are two other gigabit switches (TP-Link) that I preserved in the network and they are uplinked to the new one.

After this change the network performance instead to be optimized it degraded! A group of the PCs (about 15) use accounting software from Windows Server 2008 as mapped windows drive to load the software and uses TCP connection to the server when accessing and writing accounting data. The performance of that network after the change degraded like 10Mbps network and every operation which was fast before the change become slow.

I checked the flow control of the switch and it is disabled on every port. Also disabled the flow control and QoS of every client machine. The switch port on which is connected the accounting server I noticed the error and rejected packet counters are increasing almost every second. Every ethernet cabling is changed with brand new CAT6. Some of the PCs have 100Mbps cards and other have 1Gbps. When I manually change speed in clients to be 100Mbps FDX is better performance but not as like before the switch change. Any ideas?

share|improve this question
1  
Shuffle around cables and switches and see whether you can nail things down. Smells like some crappy hardware somewhere - finding it will require some shuffling and elimination. And check drivers - you may have some nasty ones there too. –  TomTom Jul 7 '13 at 9:27
    
I'd bet money your problem is that you have some devices that are set to full duplex. –  David Schwartz Jul 7 '13 at 10:34

1 Answer 1

If you see error counters continuously increase on specific ports, it very likely is either a duplex mismatch or bad cabling. In rare cases you might be seeing a defective PHY on either side (switch or NIC), driver problems on the station side or a buggy switch.

So first, check the duplex settings on the switch and the connected station for the port(s) in question. If any of the two sides is not set for autonegotiation, the other side will fall back to half-duplex operation. If your station is for example set to "1 Gbps, full duplex", the autonegotiation attempts initiated by the switch side will fail, so it will use 1 Gbps half duplex, causing untimely received frames to be discarded as collisions and seriously degrading the transmission performance. In general, it is a good idea to leave everything at autonegotiation, but if it already is and you still are seeing problems, try hard-setting both sides to the same parameters - buggy NICs and switches exist so autonegotiation might fail to produce correct results in a few cases.

Another thing to check for is Jumbo frames - if either side is set to not accept the over-long frames, they would be counted as "too long" or "illegal length".

Defective cabling or broken PHYs would mostly let the CRC/FCS error counters increase in a rather speedy manner. The easiest way to check if it is cabling or the PHY is by exclusion by simply replacing the components - change ports on the switch, replace NICs at the station side, replace cabling runs by known-goods.

You also should not disable flow control - in general, it is a good thing to have.

share|improve this answer
    
On the switch side the server port is set to 100Mbps FDX. On the computer side the port is set to atonagotiation. All cables are brand new and the main switch too. If everything is in autonagotiation transfer between 100Mbps and 1Gbps clients is very slow, so I force server to be 100Mbps and every computer that use accounting software also to be 100Mbps because when they are 1Gbps the loading of the .exe file (about 11MB size) from the mapped drive is about 1-2 minutes but when change to 100Mbps the load time is just 1-2 seconds. –  Jovani Jul 7 '13 at 10:00
    
@user2557719 in this case, you should set both sides to 1 gbps full duplex, check for jumbo frames (as I pointed out in my edited answer) and take a close look at which error counters are indicated exactly. –  the-wabbit Jul 7 '13 at 10:01
    
The cable between the server and the switch is about 3 meters and they are in the same room. I've changed it 3 times. –  Jovani Jul 7 '13 at 10:02
    
The counters are: Rx Drops: 1237 Rx CRC/Alignment: 1237 Rx Fragments: 1156 all other error counters are 0 –  Jovani Jul 7 '13 at 10:07
4  
Never ever set one side of a link to full duplex and the other side to auto negotiate. –  David Schwartz Jul 7 '13 at 10:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.