Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two servers both running mysql on Ubuntu 12.04.

I have an application on Server A which has to connect to Server B's database.

I have opened the my.conf file on server B and make the following edit:

#bind-address           =

Is there anything else I need to do? I still cant seem to connect.

Interestingly, I cant connect to Server B's database using the standard settings in my sql client software (Sequel Pro). I can however, connect to server B's database using Sequel Pro when using the SSH options.

Are there some security settings I need to disable?


share|improve this question

closed as unclear what you're asking by Jenny D, Ward, Dave M, Falcon Momot, mdpc Jul 8 '13 at 16:42

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

What error are you getting? – Falcon Momot Jul 8 '13 at 15:20

1 Answer 1

up vote 1 down vote accepted

Maybe port 3306 is blocked on firewall on server B

To enable remote login to mysql three things must be done:

Port 3306 opened of firewall

mysql have to bind to at least one interfaces that is available from outside not only localhost

and you mysql user can connect from other than location (user@%)

share|improve this answer
Great answer. The user I was using didnt have the correct permissions to connect from another host. Adding a % in the host field (within phpMyAdmin) fixed the issue – Bob Flemming Jul 8 '13 at 13:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.