Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently setup an ftp server using FTP 7.5 publishing service... I have tried opening ports 20,21 and that sort of worked but it hang after logging in.... saying Opening binary.....

I disabled the firewall and all works ok... So i tried following this document

but it fails to work, can anyone tell me what i am missing?

I have specifically done this as per the document above

netsh advfirewall firewall add rule name="FTP for IIS7" service=ftpsvc action=allow protocol=TCP dir=in

netsh advfirewall set global StatefulFtp disable

and set port channel range to 49152-65535..

As i say as per the document it FAILS won't even log in ... as if there is not ftp service there, with my GUESS opening port 20-21 TCP it sort of works but stops at opening binary.....

If i disabled the firewall completely that it works 100% without problems..

I am using Windows 7 (similar firewall setup to Windows 2008 server)

Any ideas really appreciated


share|improve this question
up vote 0 down vote accepted

Using IIS predefined rules for FTP and only apply

netsh advfirewall set global StatefulFtp enable

worked for me

share|improve this answer

Seems like a statefull filtering issue, i think you should enable this feature in your firewall.

share|improve this answer

Is FTP enabled for the private or public profile?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.