Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a set of instances running in an AWS VPC and I can access all the Windows instances via RDP. I have a NAT box to allow traffic out, and which also serves as an OpenVPN endpoint, through which all the RDP traffic flows. I have an SG called "RDPAccess", and any machines that need to be accessed via RDP get assigned to this SG. None of the subnets have network ACLs. All but the 'public subnets' have route tables that go via the NAT box, while the public subnets have route tables going directly via the internet gateway.

I've just tried to create a new instance, however, and I can't get RDP access to it working. It is in the same VPC, albeit a different subnet, has the RDPAccess sg assigned to it and is running the same AMI.

I can't figure out what I'm missing here to get RDP working. Further information on what I've tried so far:

Subnet? - Tried launching new instances in same subnet as other instances and it doesn't work

AMI - Tried using "launch more like this" on a working instance and it doesn't work

SG - Tried using "launch more like this" on a working instance and it doesn't work

SG - Tried creating a test SG allowing all traffic from all sources, still doesn't work

Password - Tried retrieving the password and it doesn't work

Any thoughts?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.