Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed php 5.4 using mac port. I then git cloned the phpredis repository ( https://github.com/nicolasff/phpredis ).

Then, I execute these commands:

phpize54
./configure
make && make install

The problem is that thge library gets compiled with php 5.3 and installed in this directory: /opt/local/lib/php/extensions/no-debug-non-zts-20090626/

I would need it to be compiled using php 5.4 and installed in this directory: /opt/local/lib/php54/extensions/no-debug-non-zts-20100525/

Anyone knows what I am doing wrong? Thanks in advance guys!

EDIT:

Also, when I write make test, I get this error:

PHP Warning:  PHP Startup: redis: 
Unable to initialize module
Module compiled with module API=20090626
PHP    compiled with module API=20100525
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.