Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a FreeNAS box (OS install onto USB), with 2 hard drives in it. In the GUI its only showing 1 (ada0).

How do I make it detect the other one?

They are both showing in dmesg:

ada0 at ahcich1 bus 0 scbus1 target 0 lun 0                                     
ada0: <WDC WD20EZRX-00DC0B0 80.00A80> ATA-9 SATA 3.x device                     
ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)                    
ada0: Command Queueing enabled                                                  
ada0: 1907729MB (3907029168 512 byte sectors: 16H 63S/T 16383C)                 
ada1 at ahcich2 bus 0 scbus2 target 0 lun 0                                     
ada1: <WDC WD20EZRX-00DC0B0 80.00A80> ATA-9 SATA 3.x device                     
ada1: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)                    
ada1: Command Queueing enabled                                                  
ada1: 1907729MB (3907029168 512 byte sectors: 16H 63S/T 16383C)    
...
share|improve this question
add comment

1 Answer

I found the root cause of the problem. The system hides the drive it uses not listed. If you are using a USB drive to your system, you will not have these problems.

share|improve this answer
    
The question explicitly says the I am using a USB drive. –  Petah Oct 31 '13 at 19:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.